
<!doctype html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=1">
    <meta property="fb:app_id" content="511374665719970" />
    <meta name="google-site-verification" content="60y-m3Mz2DO75aPrIBAX-UQzBRYn3LSDa5ob2Rtfzzk" />
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.thebeaverton.com/xmlrpc.php">
	<link rel="icon" href="/wp-content/uploads/2016/08/cropped-symbol-64x64.png" sizes="32x32" />
<link rel="icon" href="/wp-content/uploads/2016/08/cropped-symbol-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="/wp-content/uploads/2016/08/cropped-symbol-300x300.png" />
<meta name="msapplication-TileImage" content="/wp-content/uploads/2016/08/cropped-symbol-300x300.png" />
	
     <!--Start: DTM header to be placed in head-->
    <script src="//assets.adobedtm.com/41b7a8e674452e42c4a9f83d28f8193e334610be/satelliteLib-7d92ac1c6840397bad9d6186e49b1298bbf5fe24.js"></script>
    <!--End: DTM header to be placed in head-->

    
	<meta http-equiv="x-dns-prefetch-control" content="on">
	<link rel="dns-prefetch" href="//fonts.googleapis.com" />
	<link rel="dns-prefetch" href="//fonts.gstatic.com" />
	<link rel="dns-prefetch" href="//0.gravatar.com/" />
	<link rel="dns-prefetch" href="//2.gravatar.com/" />
	<link rel="dns-prefetch" href="//1.gravatar.com/" /><title>Graduating university student going to miss having excuse to live in own filth - The Beaverton</title>

<!-- Push notifications for this website enabled by Roost. Support for Chrome, Safari, and Firefox. (v 2.4.0) - https://goroost.com/ -->
		<script type="text/javascript">
		var ajaxurl = 'https://www.thebeaverton.com/wp-admin/admin-ajax.php';
		</script>
		
<!-- This site is optimized with the Yoast SEO plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Graduating university student going to miss having excuse to live in own filth" />
<meta property="og:description" content="MONTREAL - After four years of using his educational status to deflect judgement, Concordia student Navin Singh already misses having a solid excuse to live in his own filth." />
<meta property="og:url" content="https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/" />
<meta property="og:site_name" content="The Beaverton" />
<meta property="article:tag" content="apartment" />
<meta property="article:tag" content="Messy" />
<meta property="article:tag" content="student life" />
<meta property="article:tag" content="university" />
<meta property="article:section" content="Campus" />
<meta property="article:published_time" content="2017-04-24T18:30:37-04:00" />
<meta property="article:modified_time" content="2017-04-24T16:39:30-04:00" />
<meta property="og:updated_time" content="2017-04-24T16:39:30-04:00" />
<meta property="og:image" content="https://www.thebeaverton.com/wp-content/uploads/2017/04/Depositphotos_4574171_m-2015.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="MONTREAL &#8211; After four years of using his educational status to deflect judgement, Concordia student Navin Singh already misses having a solid excuse to live in his own filth. “Used to be that when a girl came over I could be like ‘sorry the place is dirty, way too much homework’,” said Singh as he [&hellip;]" />
<meta name="twitter:title" content="Graduating university student going to miss having excuse to live in own filth - The Beaverton" />
<meta name="twitter:image" content="https://www.thebeaverton.com/wp-content/uploads/2017/04/Depositphotos_4574171_m-2015.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Beaverton &raquo; Feed" href="https://www.thebeaverton.com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thebeaverton.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='foundation-css'  href='/wp-content/themes/thevoux-wp_beav/assets/css/foundation.css' type='text/css' media='all' />
<link rel='stylesheet' id='twentytwenty-css'  href='/wp-content/themes/thevoux-wp_beav/assets/css/twentytwenty.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-fa-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-app-css'  href='/wp-content/themes/thevoux-wp_beav/assets/css/app_r.css' type='text/css' media='all' />
<style id='thb-app-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='cyoa-css'  href='/wp-content/themes/thevoux-wp_beav/assets/css/cyoa.quiz.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-style-css'  href='/wp-content/themes/thevoux-wp_beav/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Lora%3A300%2C400%2C500%2C600%2C700%2C900%7CPlayfair+Display%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext&#038;ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='latest-posts-style-css'  href='/wp-content/plugins/latest-posts/assets/css/style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css'  href='/wp-content/plugins/wordpress-popular-posts/style/wpp.css?ver=3.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='reaction_buttons_css-css'  href='/wp-content/plugins/reaction-buttons/reaction_buttons.css?ver=4.7.4' type='text/css' media='all' />
<script type='text/javascript' src='https://www.thebeaverton.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.thebeaverton.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 8]>
<script type='text/javascript' src='https://www.thebeaverton.com/wp-includes/js/json2.min.js?ver=2015-05-03'></script>
<![endif]-->
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/tabletop.quiz.js?ver=4.7.4'></script>
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/cyoa.quiz.js?ver=4.7.4'></script>
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/jquery.event.move.js?ver=4.7.4'></script>
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/jquery.twentytwenty.js?ver=4.7.4'></script>
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/jquery.audioControls.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/lagoo_jquery.js?ver=4.7.4'></script>
<script type='text/javascript' src='/wp-content/plugins/wp-buzz-quizz/modules/js/front.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='https://www.thebeaverton.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thebeaverton.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thebeaverton.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='https://www.thebeaverton.com/?p=19032' />
<link rel="alternate" type="application/json+oembed" href="https://www.thebeaverton.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thebeaverton.com%2F2017%2F04%2Fgraduating-university-student-going-miss-excuse-live-filth%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thebeaverton.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thebeaverton.com%2F2017%2F04%2Fgraduating-university-student-going-miss-excuse-live-filth%2F&#038;format=xml" />
	<script	type='text/javascript'><!--
	function reaction_buttons_increment_button_ajax(post_id, button){
		var already_voted_text = '';
		var only_one_vote = false;
		var show_after_votes = true;
		var use_as_counter = false;
		var use_percentages = true;
		var buttons = [0,1,2,3,4,5,6];

		if(!use_as_counter && jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + button).hasClass('voted')){
			return;
		}

		if(!use_as_counter){
			// remove the href attribute before sending the request to make
			// sure no one votes more than once by clicking ten times fast
			if(only_one_vote){
				// remove all the onclicks from the posts and replace it by the
				// alert not to vote twice if set
				if(already_voted_text){
					jQuery("#reaction_buttons_post" + post_id + " .reaction_button").attr('onclick', 'javascript:alert(\'' + already_voted_text + '\');');
				}
				else{
					jQuery("#reaction_buttons_post" + post_id + " .reaction_button").removeAttr('onclick');
				}
			}
			else{
				// remove/replace only on the clicked button
				if(already_voted_text){
					jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + button).attr('onclick', 'javascript:alert(\'' + already_voted_text + '\');');
				}
				else{
					jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + button).removeAttr('onclick');
				}
			}
		}
		jQuery.ajax({
				type: "post",url: "https://www.thebeaverton.com/wp-admin/admin-ajax.php", dataType: 'json',
					data: { action: 'reaction_buttons_increment_button_php', post_id: post_id, button: button, _ajax_nonce: '7b243ab49f' },
					success: function(data){
						if(use_percentages){
							var i;
							var b;
							for(i = 0; i < buttons.length; ++i){
								b = buttons[i];
								jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + b + " .count_number").html(data['percentage'][b]);
							}
						}
                        else if(show_after_votes){
							var i;
							var b;
							for(i = 0; i < buttons.length; ++i){
								b = buttons[i];
								jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + b + " .count_number").html(data['counts'][b]);
							}
						}
						else{
							jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + button + " .count_number").html(data['count']);
						}
						if(only_one_vote){
							jQuery("#reaction_buttons_post" + post_id + " .reaction_button").addClass('voted');
							jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + button).addClass('rb_chosen');
						}
						else{
							jQuery("#reaction_buttons_post" + post_id + " .reaction_button_" + button).addClass('voted');
						}
                        if(show_after_votes){
							jQuery("#reaction_buttons_post" + post_id + " .reaction_button .braces").removeAttr('style');
						}
					}
			});
		}
	--></script>
	<meta property="fb:app_id" content="" />				<!-- WordPress Popular Posts v3.3.4 -->
				<script type="text/javascript">

					var sampling_active = 0;
					var sampling_rate   = 100;
					var do_request = false;

					if ( !sampling_active ) {
						do_request = true;
					} else {
						var num = Math.floor(Math.random() * sampling_rate) + 1;
						do_request = ( 1 === num );
					}

					if ( do_request ) {

						/* Create XMLHttpRequest object and set variables */
						var xhr = ( window.XMLHttpRequest )
						  ? new XMLHttpRequest()
						  : new ActiveXObject( "Microsoft.XMLHTTP" ),
						url = 'https://www.thebeaverton.com/wp-admin/admin-ajax.php',
						params = 'action=update_views_ajax&token=898e2b45f3&wpp_id=19032';
						/* Set request method and target URL */
						xhr.open( "POST", url, true );
						/* Set request header */
						xhr.setRequestHeader( "Content-type", "application/x-www-form-urlencoded" );
						/* Hook into onreadystatechange */
						xhr.onreadystatechange = function() {
							if ( 4 === xhr.readyState && 200 === xhr.status ) {
								if ( window.console && window.console.log ) {
									window.console.log( xhr.responseText );
								}
							}
						};
						/* Send request */
						xhr.send( params );

					}

				</script>
				<!-- End WordPress Popular Posts v3.3.4 -->
				<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="icon" href="/wp-content/uploads/2016/08/cropped-symbol-64x64.png" sizes="32x32" />
<link rel="icon" href="/wp-content/uploads/2016/08/cropped-symbol-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="/wp-content/uploads/2016/08/cropped-symbol-300x300.png" />
<meta name="msapplication-TileImage" content="/wp-content/uploads/2016/08/cropped-symbol-300x300.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>    
   <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

      ga('create', 'UA-83588851-1', 'auto');
      ga('send', 'pageview');


    var on_m = 0;
        
        
    (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6305909245661120",
    enable_page_level_ads: true
    });
    
        
    var digitalData = digitalData || {};
    digitalData = {
        producer: {
            applicationId: "1516.11413.142579"
        },
    };
    
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
    n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
    document,'script','https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1702687910047675');
    fbq('track', 'PageView');

    </script>
    <noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=1702687910047675&ev=PageView&noscript=1"
    /></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

    <!--Copy and Paste Data Layer at bottom of head-->

</head>
<body class="post-template-default single single-post postid-19032 single-format-standard wpb-js-composer js-comp-ver-4.12 vc_responsive" data-themeurl="/wp-content/themes/thevoux-wp_beav">
    
    <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
    
    <div id="wrapper">
	<!-- Start Mobile Menu -->
<nav id="mobile-menu">
	<div class="custom_scroll" id="menu-scroll">
		<div>
			<a href="#" class="close">×</a>
			<img src="/wp-content/uploads/2016/08/new_head.png" class="logoimg" alt="The Beaverton"/>
						  <ul id="menu-main-menu" class="thb-mobile-menu"><li id="menu-item-13617" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-13617"><a href="https://www.thebeaverton.com/about-the-show/">WATCH THE SERIES WED, 10PM ON COMEDY</a></li>
<li id="menu-item-5863" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5863"><a href="https://www.thebeaverton.com/news/national/">National</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-11001" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11001"><a href="https://www.thebeaverton.com/news/national/">National</a></li>
	<li id="menu-item-10981" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10981"><a href="https://www.thebeaverton.com/news/local/">Local</a></li>
	<li id="menu-item-10984" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10984"><a href="https://www.thebeaverton.com/news/toronto/">Toronto</a></li>
	<li id="menu-item-10982" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10982"><a href="https://www.thebeaverton.com/news/montreal/">Montreal</a></li>
	<li id="menu-item-10986" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10986"><a href="https://www.thebeaverton.com/news/vancouver/">Vancouver</a></li>
	<li id="menu-item-10983" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10983"><a href="https://www.thebeaverton.com/news/north/">North</a></li>
	<li id="menu-item-10979" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10979"><a href="https://www.thebeaverton.com/news/campus/">Campus</a></li>
	<li id="menu-item-10985" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10985"><a href="https://www.thebeaverton.com/news/university-reviews/">University Reviews</a></li>
	<li id="menu-item-10980" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10980"><a href="https://www.thebeaverton.com/news/canada-votes-2015/">Canada Votes 2015</a></li>
</ul>
</li>
<li id="menu-item-5881" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5881"><a href="https://www.thebeaverton.com/news/world/">World</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-11005" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11005"><a href="https://www.thebeaverton.com/news/world/">World</a></li>
	<li id="menu-item-85" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://www.thebeaverton.com/news/us/">U.S.</a></li>
	<li id="menu-item-10987" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10987"><a href="https://www.thebeaverton.com/news/historical-archives/">Historical Archives</a></li>
</ul>
</li>
<li id="menu-item-5915" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5915"><a href="https://www.thebeaverton.com/sports/">Sports</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-11006" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11006"><a href="https://www.thebeaverton.com/news/sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-5866" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5866"><a href="https://www.thebeaverton.com/news/business/">Business</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-11309" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11309"><a href="https://www.thebeaverton.com/news/business/">Business</a></li>
</ul>
</li>
<li id="menu-item-10989" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10989"><a href="https://www.thebeaverton.com/news/culture/">Culture</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-11008" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11008"><a href="https://www.thebeaverton.com/news/culture/">Culture</a></li>
	<li id="menu-item-10990" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10990"><a href="https://www.thebeaverton.com/news/comics/">Comics</a></li>
</ul>
</li>
<li id="menu-item-10991" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10991"><a href="https://www.thebeaverton.com/news/lifestyle/">Lifestyle</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-11009" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11009"><a href="https://www.thebeaverton.com/news/lifestyle/">Lifestyle</a></li>
	<li id="menu-item-10993" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10993"><a href="https://www.thebeaverton.com/news/health/">Health</a></li>
	<li id="menu-item-10997" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10997"><a href="https://www.thebeaverton.com/news/opinion/">Opinion</a></li>
	<li id="menu-item-10998" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10998"><a href="https://www.thebeaverton.com/news/stats/">Stats</a></li>
	<li id="menu-item-10992" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10992"><a href="https://www.thebeaverton.com/news/classifieds/">Classifieds</a></li>
	<li id="menu-item-10995" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10995"><a href="https://www.thebeaverton.com/news/krysten/">Krysten</a></li>
	<li id="menu-item-10996" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10996"><a href="https://www.thebeaverton.com/news/lifestyle/magazine/">Magazine</a></li>
</ul>
</li>
<li id="menu-item-5884" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5884"><a href="https://www.thebeaverton.com/beavfeed/">BeavFeed</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-11310" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11310"><a href="https://www.thebeaverton.com/news/beavfeed/">Beavfeed</a></li>
	<li id="menu-item-10975" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10975"><a href="https://www.thebeaverton.com/news/choice-your-own-adventure/">Choice Your Own Adventure</a></li>
	<li id="menu-item-10977" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10977"><a href="https://www.thebeaverton.com/news/quiz/">Quiz</a></li>
	<li id="menu-item-10978" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10978"><a href="https://www.thebeaverton.com/news/slideshow/">Slideshow</a></li>
	<li id="menu-item-15825" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15825"><a href="https://www.thebeaverton.com/news/guide-to/">Guide To/How To</a></li>
</ul>
</li>
<li id="menu-item-12364" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12364"><a href="https://www.thebeaverton.com/news/video/">Video</a><span><i class="fa fa-angle-down"></i></span>
<ul class="sub-menu">
	<li id="menu-item-12365" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12365"><a href="https://www.thebeaverton.com/news/video/">Video</a></li>
	<li id="menu-item-15920" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-15920"><a href="http://www.thecomedynetwork.ca/Shows/TheBeaverton">Watch the Show!</a></li>
</ul>
</li>
</ul>									<div class="menu-footer">
							</div>
		</div>
	</div>
</nav>
<!-- End Mobile Menu -->	
	<!-- Start Content Container -->
	<section id="content-container">
		<!-- Start Content Click Capture -->
		<div class="click-capture"></div>
		<!-- End Content Click Capture -->
		
<!-- Start Header -->
<div class="header_container style1">
	<header class="header style1" role="banner">
		<div class="header_top cf">
			<div class="row full-width-row">
				<div class="small-3 large-4 columns toggle-holder">
					<div>
						<a href="#" class="mobile-toggle ">
							<div>
								<span></span><span></span><span></span>
							</div>
						</a>
						<a href="https://www.thebeaverton.com" class="logolink" title="The Beaverton"><img src="/wp-content/uploads/2016/08/new_head.png" class="logofixed" alt="The Beaverton"/></a>
					</div>
				</div>
				<div class="small-6 large-4 columns logo text-center">
					<h6 id="page-title">Graduating university student going to...</h6>					<a href="https://www.thebeaverton.com" class="logolink" title="The Beaverton">
						<img src="/wp-content/uploads/2016/08/new_head.png" class="logoimg" alt="The Beaverton"/>
					</a>
				</div>
				<div class="small-3 large-4 columns social-holder style2">
					<div>
								<a href="https://www.facebook.com/TheBeaverton/" class="facebook icon-1x" target="_blank"><i class="fa fa-facebook"></i></a>
				<a href="http://twitter.com/TheBeaverton" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i></a>
				<a href="http://instagram.com/thebeaverton" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i></a>
									<a href="https://www.youtube.com/channel/UCxraWf1_uR8isJ7S9zfEo5w" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i></a>
								 	<aside id="quick_search">
		<svg xmlns="http://www.w3.org/2000/svg" version="1.1" id="search_icon" x="0" y="0" width="20" height="20" viewBox="0 0 20 20" enable-background="new 0 0 20 20" xml:space="preserve"><path d="M19.8 18.4l-5.4-5.4c1.1-1.4 1.8-3.1 1.8-5 0-4.4-3.6-8-8-8 -4.4 0-8 3.6-8 8s3.6 8 8 8c1.8 0 3.5-0.6 4.8-1.6l5.4 5.4c0.2 0.2 0.5 0.3 0.7 0.3 0.3 0 0.5-0.1 0.7-0.3C20.2 19.4 20.2 18.8 19.8 18.4zM2.1 8.1c0-3.3 2.7-6 6-6s6 2.7 6 6c0 3.3-2.7 6-6 6S2.1 11.4 2.1 8.1z"/></svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.thebeaverton.com/">
    <fieldset>
    	<input name="s" type="text" id="s" placeholder="Search" class="small-12">
    </fieldset>
</form>
<!-- End SearchForm -->	</aside>
											</div>
				</div>
			</div>
						<span class="progress"></span>
					</div>
				<nav id="full-menu" role="navigation" class="">
						  <ul id="menu-main-menu-1" class="full-menu nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13617"><a href="https://www.thebeaverton.com/about-the-show/">WATCH THE SERIES WED, 10PM ON COMEDY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5863 menu-item-mega-parent"><a href="https://www.thebeaverton.com/news/national/">National</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11001"><a href="https://www.thebeaverton.com/news/national/"><i class="fa fa-arrow-circle-o-right"></i> National</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10981"><a href="https://www.thebeaverton.com/news/local/"><i class="fa fa-arrow-circle-o-right"></i> Local</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10984"><a href="https://www.thebeaverton.com/news/toronto/"><i class="fa fa-arrow-circle-o-right"></i> Toronto</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10982"><a href="https://www.thebeaverton.com/news/montreal/"><i class="fa fa-arrow-circle-o-right"></i> Montreal</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10986"><a href="https://www.thebeaverton.com/news/vancouver/"><i class="fa fa-arrow-circle-o-right"></i> Vancouver</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10983"><a href="https://www.thebeaverton.com/news/north/"><i class="fa fa-arrow-circle-o-right"></i> North</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10979"><a href="https://www.thebeaverton.com/news/campus/"><i class="fa fa-arrow-circle-o-right"></i> Campus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10985"><a href="https://www.thebeaverton.com/news/university-reviews/"><i class="fa fa-arrow-circle-o-right"></i> University Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10980"><a href="https://www.thebeaverton.com/news/canada-votes-2015/"><i class="fa fa-arrow-circle-o-right"></i> Canada Votes 2015</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19026 type-post status-publish format-standard has-post-thumbnail hentry category-national tag-rex-murphy tag-snapping-turtle" id="post-19026" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/rex-murphy-safely-re-enters-ontario-snapping-turtle-hunt-permanently-banned/" title="Rex Murphy safely re-enters Ontario after snapping turtle hunt permanently banned">
			            <img src="/wp-content/uploads/2017/04/Rex-Murphy-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/rex-murphy-safely-re-enters-ontario-snapping-turtle-hunt-permanently-banned/" title="Rex Murphy safely re-enters Ontario after snapping turtle hunt permanently banned">Rex Murphy safely re-enters Ontario after snapping turtle hunt permanently banned</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19015 type-post status-publish format-standard has-post-thumbnail hentry category-national tag-canada-150 tag-canadian-history tag-justin-trudeau tag-trudeau tag-world-war-i" id="post-19015" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/75-canada-150-budget-spent-hiding-worst-parts-national-history/" title="75% of Canada 150 budget spent on hiding worst parts of national history">
			            <img src="/wp-content/uploads/2017/04/flag-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/75-canada-150-budget-spent-hiding-worst-parts-national-history/" title="75% of Canada 150 budget spent on hiding worst parts of national history">75% of Canada 150 budget spent on hiding worst parts of national history</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19001 type-post status-publish format-standard has-post-thumbnail hentry category-national tag-iceberg tag-newfoundland tag-sinking tag-titanic" id="post-19001" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/newfoundland-sunk-collision-iceberg/" title="Newfoundland sunk after collision with iceberg">
			            <img src="/wp-content/uploads/2017/04/Newfoundland-Sunk-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/newfoundland-sunk-collision-iceberg/" title="Newfoundland sunk after collision with iceberg">Newfoundland sunk after collision with iceberg</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18971 type-post status-publish format-standard has-post-thumbnail hentry category-national tag-canada-us-relations tag-cheese tag-dairy-commission tag-lawrence-macaulay tag-trump" id="post-18971" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/trumps-canadian-dairy-criticism-forces-federal-government-declare-cheesecon-1/" title="Trump’s Canadian dairy criticism forces federal government to declare CHEESECON 1">
			            <img src="/wp-content/uploads/2017/04/Emergency-Ops-Centre-Fromage-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/trumps-canadian-dairy-criticism-forces-federal-government-declare-cheesecon-1/" title="Trump’s Canadian dairy criticism forces federal government to declare CHEESECON 1">Trump’s Canadian dairy criticism forces federal government to declare CHEESECON 1</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18929 type-post status-publish format-standard has-post-thumbnail hentry category-local tag-antibiotic tag-bacteria tag-bacterium tag-e-coli" id="post-18929" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/radicalized-bacterium-joins-antibiotic-resistance/" title="Radicalized bacterium joins antibiotic resistance">
			            <img src="/wp-content/uploads/2017/04/16598492368_b20c0e7c43_o-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/radicalized-bacterium-joins-antibiotic-resistance/" title="Radicalized bacterium joins antibiotic resistance">Radicalized bacterium joins antibiotic resistance</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18905 type-post status-publish format-standard has-post-thumbnail hentry category-local tag-activists tag-bra tag-club" id="post-18905" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/local-strapless-bras-woman-just-going-slide-night/" title="Local strapless bra’s woman just going to slide up all night">
			            <img src="/wp-content/uploads/2017/04/Depositphotos_129783146_s-2015-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/local-strapless-bras-woman-just-going-slide-night/" title="Local strapless bra’s woman just going to slide up all night">Local strapless bra’s woman just going to slide up all night</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18902 type-post status-publish format-standard has-post-thumbnail hentry category-local tag-cereal tag-cheerios" id="post-18902" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/frightened-cheerio-enters-uncharted-void-plastic-bag-cereal-box/" title="Frightened Cheerio enters uncharted void between plastic bag and cereal box">
			            <img src="/wp-content/uploads/2017/04/Yogurt_Burst_Cheerios-240x150.png" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/frightened-cheerio-enters-uncharted-void-plastic-bag-cereal-box/" title="Frightened Cheerio enters uncharted void between plastic bag and cereal box">Frightened Cheerio enters uncharted void between plastic bag and cereal box</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18881 type-post status-publish format-standard has-post-thumbnail hentry category-local" id="post-18881" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/report-not-supposed-make-sound/" title="Report: It not supposed to make that sound">
			            <img src="/wp-content/uploads/2017/04/93549797_17c01bb0dd_o-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/report-not-supposed-make-sound/" title="Report: It not supposed to make that sound">Report: It not supposed to make that sound</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18994 type-post status-publish format-standard has-post-thumbnail hentry category-ontario category-politics category-toronto tag-condo tag-condominium tag-foreign-buyers-tax tag-housing tag-housing-market tag-kathleen-wynne tag-legislative-building tag-legislature tag-liberal-party-of-ontario tag-liberals tag-market tag-mpp tag-ontario tag-queens-park tag-rent-control tag-tax" id="post-18994" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/ontario-liberals-combat-housing-crisis-adding-58-storey-condo-queens-park/" title="Ontario Liberals combat housing crisis by adding 58 storey condo to Queen’s Park">
			            <img src="/wp-content/uploads/2017/04/Queens-Park-Condo-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/ontario-liberals-combat-housing-crisis-adding-58-storey-condo-queens-park/" title="Ontario Liberals combat housing crisis by adding 58 storey condo to Queen’s Park">Ontario Liberals combat housing crisis by adding 58 storey condo to Queen’s Park</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18918 type-post status-publish format-standard has-post-thumbnail hentry category-toronto tag-streetcar tag-toronto-2 tag-ttc tag-ttc-shop" id="post-18918" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/ttc-shop-sell-giant-sticks-operators-still-use-move-streetcar-tracks/" title="TTC Shop to sell giant sticks operators still use to move streetcar tracks">
			            <img src="/wp-content/uploads/2017/04/Streetcar-stick-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/ttc-shop-sell-giant-sticks-operators-still-use-move-streetcar-tracks/" title="TTC Shop to sell giant sticks operators still use to move streetcar tracks">TTC Shop to sell giant sticks operators still use to move streetcar tracks</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18785 type-post status-publish format-standard has-post-thumbnail hentry category-toronto tag-cn-tower-climb tag-death tag-gatorade" id="post-18785" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/cn-tower-climber-passes-frozen-bodies-last-years-climb/" title="CN Tower climber passes frozen bodies from last year’s climb">
			            <img src="/wp-content/uploads/2017/04/2309709585_c5147f6f9e_o-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/cn-tower-climber-passes-frozen-bodies-last-years-climb/" title="CN Tower climber passes frozen bodies from last year’s climb">CN Tower climber passes frozen bodies from last year’s climb</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18682 type-post status-publish format-standard has-post-thumbnail hentry category-toronto tag-condo tag-condominium tag-fire tag-flames tag-housing tag-market tag-real-estate tag-toronto-2" id="post-18682" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/downtown-toronto-condo-engulfed-flames-sells-1-2-million/" title="Downtown Toronto condo engulfed in flames sells for $1.2 million">
			            <img src="/wp-content/uploads/2017/04/Toronto-Condo-fire-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/downtown-toronto-condo-engulfed-flames-sells-1-2-million/" title="Downtown Toronto condo engulfed in flames sells for $1.2 million">Downtown Toronto condo engulfed in flames sells for $1.2 million</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18891 type-post status-publish format-standard has-post-thumbnail hentry category-montreal tag-alive375 tag-vive375" id="post-18891" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/montreal-celebrates-50th-anniversary-325th-anniversary-celebrations/" title="Montreal celebrates 50th anniversary of 325th anniversary celebrations">
			            <img src="/wp-content/uploads/2017/04/375-Montreal-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/montreal-celebrates-50th-anniversary-325th-anniversary-celebrations/" title="Montreal celebrates 50th anniversary of 325th anniversary celebrations">Montreal celebrates 50th anniversary of 325th anniversary celebrations</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18404 type-post status-publish format-standard has-post-thumbnail hentry category-montreal tag-ice-storm tag-montreal tag-quebec tag-snow tag-snow-storm tag-winter" id="post-18404" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/quebec-apologizes-citizens-still-trapped-1998-ice-storm/" title="Quebec apologizes to citizens still trapped by 1998 ice storm">
			            <img src="/wp-content/uploads/2017/03/640px-Neige_Montreal-240x150.jpeg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/quebec-apologizes-citizens-still-trapped-1998-ice-storm/" title="Quebec apologizes to citizens still trapped by 1998 ice storm">Quebec apologizes to citizens still trapped by 1998 ice storm</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18255 type-post status-publish format-standard has-post-thumbnail hentry category-montreal tag-fear tag-festival-des-casteliers tag-marionettes tag-puppets" id="post-18255" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/marionette-festival-showcases-years-top-nightmares/" title="Marionette festival showcases this year&#8217;s top nightmares">
			            <img src="/wp-content/uploads/2017/03/640px-Marionnette-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/marionette-festival-showcases-years-top-nightmares/" title="Marionette festival showcases this year&#8217;s top nightmares">Marionette festival showcases this year&#8217;s top nightmares</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17762 type-post status-publish format-video has-post-thumbnail hentry category-guide-to category-montreal category-video tag-featured-post tag-guide-to tag-montreal post_format-post-format-video" id="post-17762" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/guide-to-montreal/" title="Guide To: Montreal">
			            <img src="/wp-content/uploads/2017/02/guide-to-montreal-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/guide-to-montreal/" title="Guide To: Montreal">Guide To: Montreal</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18438 type-post status-publish format-standard has-post-thumbnail hentry category-vancouver tag-amor-de-cosmos tag-bc tag-canadian-history tag-hipsters" id="post-18438" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/historians-confirm-bcs-second-premier-canadas-first-hipster/" title="Historians confirm BC&#8217;s second premier was Canada&#8217;s first hipster">
			            <img src="/wp-content/uploads/2017/03/Amor_de_Cosmos-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/historians-confirm-bcs-second-premier-canadas-first-hipster/" title="Historians confirm BC&#8217;s second premier was Canada&#8217;s first hipster">Historians confirm BC&#8217;s second premier was Canada&#8217;s first hipster</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17941 type-post status-publish format-standard has-post-thumbnail hentry category-vancouver tag-bullying tag-pink-shirt-day" id="post-17941" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/school-boy-bullied-not-wearing-pink-shirt-today/" title="School boy bullied for not wearing pink shirt today">
			            <img src="/wp-content/uploads/2017/02/Non-pink-shirt-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/school-boy-bullied-not-wearing-pink-shirt-today/" title="School boy bullied for not wearing pink shirt today">School boy bullied for not wearing pink shirt today</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17737 type-post status-publish format-standard has-post-thumbnail hentry category-vancouver tag-burning-garbage-bag tag-surrey" id="post-17737" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/surrey-bc-name-burning-garbage-bag-citys-official-bird/" title="Surrey, BC to name Burning Garbage Bag city’s official bird">
			            <img src="/wp-content/uploads/2017/02/Dumpster-fire-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/surrey-bc-name-burning-garbage-bag-citys-official-bird/" title="Surrey, BC to name Burning Garbage Bag city’s official bird">Surrey, BC to name Burning Garbage Bag city’s official bird</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17690 type-post status-publish format-standard has-post-thumbnail hentry category-vancouver tag-alimony tag-galentines tag-galentines-day tag-mens-rights-activist tag-mra tag-parks-and-recreation tag-vancouver-2" id="post-17690" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/mens-rights-activists-claim-galentines-day-discriminatory-demand-malentines-day/" title="Men&#8217;s Rights Activists claim &#8216;Galentine&#8217;s Day&#8217; discriminatory; demand &#8216;Malentine&#8217;s Day&#8217;">
			            <img src="/wp-content/uploads/2017/02/Four_girls_friends_001-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/mens-rights-activists-claim-galentines-day-discriminatory-demand-malentines-day/" title="Men&#8217;s Rights Activists claim &#8216;Galentine&#8217;s Day&#8217; discriminatory; demand &#8216;Malentine&#8217;s Day&#8217;">Men&#8217;s Rights Activists claim &#8216;Galentine&#8217;s Day&#8217; discriminatory; demand &#8216;Malentine&#8217;s Day&#8217;</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18816 type-post status-publish format-standard has-post-thumbnail hentry category-north tag-bylaw tag-city-of-whitehorse tag-kevlar-vests tag-lav" id="post-18816" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/whitehorse-bylaw-officers-given-light-armoured-vehicles/" title="Whitehorse bylaw officers given light armoured vehicles">
			            <img src="/wp-content/uploads/2017/04/LAV-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/whitehorse-bylaw-officers-given-light-armoured-vehicles/" title="Whitehorse bylaw officers given light armoured vehicles">Whitehorse bylaw officers given light armoured vehicles</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18160 type-post status-publish format-standard has-post-thumbnail hentry category-north tag-bombardier tag-intercity-mall tag-kathleen-wynne tag-north tag-northern-ontario tag-ontario tag-subway tag-thunder-bay tag-train tag-transit" id="post-18160" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/thunder-bay-transit-opens-single-subway-station/" title="Thunder Bay transit opens single subway station">
			            <img src="/wp-content/uploads/2017/03/Thunder-Bay-subway-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/thunder-bay-transit-opens-single-subway-station/" title="Thunder Bay transit opens single subway station">Thunder Bay transit opens single subway station</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17957 type-post status-publish format-standard has-post-thumbnail hentry category-north tag-power-outage tag-sourdough-rendezvous-festival tag-yukon" id="post-17957" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/yukons-sourdough-rendezvous-festival-end-traditional-territory-wide-power-outage/" title="Yukon&#8217;s Sourdough-Rendezvous Festival to end with a traditional territory-wide power outage">
			            <img src="/wp-content/uploads/2017/02/Power-outage-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/yukons-sourdough-rendezvous-festival-end-traditional-territory-wide-power-outage/" title="Yukon&#8217;s Sourdough-Rendezvous Festival to end with a traditional territory-wide power outage">Yukon&#8217;s Sourdough-Rendezvous Festival to end with a traditional territory-wide power outage</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17466 type-post status-publish format-standard has-post-thumbnail hentry category-north tag-northwestel tag-yukon" id="post-17466" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/northwestel-study-determines-fastest-internet-canadas-north/" title="Northwestel study determines it has the fastest, only internet in Canada&#8217;s North">
			            <img src="/wp-content/uploads/2017/02/Northern-Canadas-downloading-speeds-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/northwestel-study-determines-fastest-internet-canadas-north/" title="Northwestel study determines it has the fastest, only internet in Canada&#8217;s North">Northwestel study determines it has the fastest, only internet in Canada&#8217;s North</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19032 type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-apartment tag-messy tag-student-life tag-university" id="post-19032" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/" title="Graduating university student going to miss having excuse to live in own filth">
			            <img src="/wp-content/uploads/2017/04/Depositphotos_4574171_m-2015-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/" title="Graduating university student going to miss having excuse to live in own filth">Graduating university student going to miss having excuse to live in own filth</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18279 type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-carleton tag-weight-scales" id="post-18279" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/carleton-university-gym-replaces-weight-scales-maslows-hierarchy-needs-scale/" title="Carleton University gym replaces weight scales with Maslow&#8217;s Hierarchy of Needs scale">
			            <img src="/wp-content/uploads/2017/03/Bathroom-Scale-Maslow-Scale-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/carleton-university-gym-replaces-weight-scales-maslows-hierarchy-needs-scale/" title="Carleton University gym replaces weight scales with Maslow&#8217;s Hierarchy of Needs scale">Carleton University gym replaces weight scales with Maslow&#8217;s Hierarchy of Needs scale</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17877 type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-groundhog-day tag-mfa" id="post-17877" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/mfa-student-7th-year-realizes-hes-living-plot-groundhog-day/" title="MFA student in 7th year realizes he’s living the plot of Groundhog Day">
			            <img src="/wp-content/uploads/2017/02/MFA-Student-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/mfa-student-7th-year-realizes-hes-living-plot-groundhog-day/" title="MFA student in 7th year realizes he’s living the plot of Groundhog Day">MFA student in 7th year realizes he’s living the plot of Groundhog Day</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17752 type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-fascism tag-jews tag-judaism tag-mcgill tag-ssmu tag-zionism" id="post-17752" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/mcgill-students-endorse-plan-battle-fascism-punching-jews/" title="McGill students endorse plan to battle fascism by punching Jews">
			            <img src="/wp-content/uploads/2017/02/McGill-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/mcgill-students-endorse-plan-battle-fascism-punching-jews/" title="McGill students endorse plan to battle fascism by punching Jews">McGill students endorse plan to battle fascism by punching Jews</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2987 type-post status-publish format-standard has-post-thumbnail hentry category-university-reviews tag-acadia-university" id="post-2987" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/10/acadia-university-university-reviews-2014/" title="Acadia University: The Beaverton University Reviews">
			            <img src="/wp-content/uploads/2014/10/Fountain-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/10/acadia-university-university-reviews-2014/" title="Acadia University: The Beaverton University Reviews">Acadia University: The Beaverton University Reviews</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2961 type-post status-publish format-standard has-post-thumbnail hentry category-university-reviews tag-dalhousie-university" id="post-2961" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/10/dalhousie-university-university-reviews-2014/" title="Dalhousie University: The Beaverton University Reviews">
			            <img src="/wp-content/uploads/2014/10/Dalhousie-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/10/dalhousie-university-university-reviews-2014/" title="Dalhousie University: The Beaverton University Reviews">Dalhousie University: The Beaverton University Reviews</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2426 type-post status-publish format-standard has-post-thumbnail hentry category-university-reviews tag-ocad-university tag-toronto-2" id="post-2426" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/04/ocad-university/" title="OCAD University: University Reviews 2014">
			            <img src="/wp-content/uploads/2014/04/OCADU-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/04/ocad-university/" title="OCAD University: University Reviews 2014">OCAD University: University Reviews 2014</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2011 type-post status-publish format-standard has-post-thumbnail hentry category-university-reviews tag-history tag-ryerson-university" id="post-2011" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/01/ryerson-university-university-reviews-2013/" title="Ryerson University: The Beaverton University Reviews">
			            <img src="/wp-content/uploads/2014/01/Ryerson-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/01/ryerson-university-university-reviews-2013/" title="Ryerson University: The Beaverton University Reviews">Ryerson University: The Beaverton University Reviews</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-4067 type-post status-publish format-standard has-post-thumbnail hentry category-canada-votes-2015 tag-house-of-commons tag-liberal-party tag-ndp tag-thomas-mulcair" id="post-4067" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2015/10/ndp-claim-liberals-stole-their-idea-to-form-majority-government/" title="NDP claim Liberals stole their idea to form majority government">
			            <img src="/wp-content/uploads/2015/10/Mulcair-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2015/10/ndp-claim-liberals-stole-their-idea-to-form-majority-government/" title="NDP claim Liberals stole their idea to form majority government">NDP claim Liberals stole their idea to form majority government</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-4065 type-post status-publish format-standard has-post-thumbnail hentry category-canada-votes-2015 tag-conservative-party tag-globe-and-mail tag-stephen-harper tag-toronto-sun tag-university-of-toronto" id="post-4065" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2015/10/sun-newspapers-still-reporting-harper-majority/" title="Sun newspapers still reporting Harper majority">
			            <img src="/wp-content/uploads/2015/10/SunHarper-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2015/10/sun-newspapers-still-reporting-harper-majority/" title="Sun newspapers still reporting Harper majority">Sun newspapers still reporting Harper majority</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-4057 type-post status-publish format-standard has-post-thumbnail hentry category-canada-votes-2015 tag-great-depression tag-social-credit tag-stephen-harper tag-winnipeg" id="post-4057" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2015/10/90-year-old-who-has-never-voted-proudly-casts-first-ballot-for-social-credit-party/" title="90-year-old who has never voted proudly casts first ballot for Social Credit party">
			            <img src="/wp-content/uploads/2015/10/80d315f5dc26569c9004e0b0b654ba3d-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2015/10/90-year-old-who-has-never-voted-proudly-casts-first-ballot-for-social-credit-party/" title="90-year-old who has never voted proudly casts first ballot for Social Credit party">90-year-old who has never voted proudly casts first ballot for Social Credit party</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-4055 type-post status-publish format-standard has-post-thumbnail hentry category-canada-votes-2015 tag-conservative-party tag-fox-sports tag-jose-bautista tag-justin-trudeau tag-kansas-city-royals tag-skydome tag-toronto-blue-jays" id="post-4055" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2015/10/conservatives-unveil-last-minute-attack-ad-accusing-justin-of-supporting-kansas-city/" title="Conservatives unveil last minute attack ad accusing Justin of supporting Kansas City">
			            <img src="/wp-content/uploads/2015/10/Trudeau-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2015/10/conservatives-unveil-last-minute-attack-ad-accusing-justin-of-supporting-kansas-city/" title="Conservatives unveil last minute attack ad accusing Justin of supporting Kansas City">Conservatives unveil last minute attack ad accusing Justin of supporting Kansas City</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5881 menu-item-mega-parent"><a href="https://www.thebeaverton.com/news/world/">World</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11005"><a href="https://www.thebeaverton.com/news/world/"><i class="fa fa-arrow-circle-o-right"></i> World</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://www.thebeaverton.com/news/us/"><i class="fa fa-arrow-circle-o-right"></i> U.S.</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10987"><a href="https://www.thebeaverton.com/news/historical-archives/"><i class="fa fa-arrow-circle-o-right"></i> Historical Archives</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18922 type-post status-publish format-video has-post-thumbnail hentry category-video category-world tag-israel tag-middle-east tag-palestine post_format-post-format-video" id="post-18922" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/learn-everything-need-know-israel-palestine-conflict-just-60-seconds/" title="Learn EVERYTHING you need to know about the Israel-Palestine conflict in just 60 seconds">
			            <img src="/wp-content/uploads/2017/04/BV-Israel-Palestine-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/learn-everything-need-know-israel-palestine-conflict-just-60-seconds/" title="Learn EVERYTHING you need to know about the Israel-Palestine conflict in just 60 seconds">Learn EVERYTHING you need to know about the Israel-Palestine conflict in just 60 seconds</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18866 type-post status-publish format-standard has-post-thumbnail hentry category-world tag-canadian-parliament tag-gender-equity tag-malala" id="post-18866" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/malala-addresses-dysfunctional-foreign-legislature-26-representatives-women/" title="Malala addresses dysfunctional foreign legislature where only 26% of representatives are women">
			            <img src="/wp-content/uploads/2017/04/Malala-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/malala-addresses-dysfunctional-foreign-legislature-26-representatives-women/" title="Malala addresses dysfunctional foreign legislature where only 26% of representatives are women">Malala addresses dysfunctional foreign legislature where only 26% of representatives are women</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18833 type-post status-publish format-video has-post-thumbnail hentry category-video category-world tag-featured-post tag-north-korea post_format-post-format-video" id="post-18833" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/wont-believe-going-north-korea-right-now/" title="You WON&#8217;T BELIEVE what is going on in North Korea right now">
			            <img src="/wp-content/uploads/2017/02/bv-plus-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/wont-believe-going-north-korea-right-now/" title="You WON&#8217;T BELIEVE what is going on in North Korea right now">You WON&#8217;T BELIEVE what is going on in North Korea right now</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18536 type-post status-publish format-video has-post-thumbnail hentry category-video category-world tag-arctic tag-environment tag-featured-post post_format-post-format-video" id="post-18536" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/canada-stuck-two-huge-military-powers-run-nightmare-men/" title="Why the fight over the Arctic will doom us all">
			            <img src="/wp-content/uploads/2017/03/bvplus-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/canada-stuck-two-huge-military-powers-run-nightmare-men/" title="Why the fight over the Arctic will doom us all">Why the fight over the Arctic will doom us all</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18944 type-post status-publish format-standard has-post-thumbnail hentry category-us tag-alex-jones tag-growing-pains tag-infowars tag-jetsons tag-pizza tag-texas" id="post-18944" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/beloved-character-alex-jones-jumps-shark-child-custody-storyline/" title="Beloved character ‘Alex Jones’ jumps shark with child custody storyline">
			            <img src="/wp-content/uploads/2017/04/Alex-Jones-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/beloved-character-alex-jones-jumps-shark-child-custody-storyline/" title="Beloved character ‘Alex Jones’ jumps shark with child custody storyline">Beloved character ‘Alex Jones’ jumps shark with child custody storyline</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18894 type-post status-publish format-standard has-post-thumbnail hentry category-us tag-donald-trump tag-kim-jong-un tag-military tag-nuclear tag-pacific" id="post-18894" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/unhinged-authoritarian-son-privilege-plans-missile-launch/" title="Unhinged authoritarian son of privilege plans missile launch against same">
			            <img src="/wp-content/uploads/2017/04/Kim-Trump-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/unhinged-authoritarian-son-privilege-plans-missile-launch/" title="Unhinged authoritarian son of privilege plans missile launch against same">Unhinged authoritarian son of privilege plans missile launch against same</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18611 type-post status-publish format-standard has-post-thumbnail hentry category-us tag-immunity tag-michael-flynn tag-russia-hacking tag-trump" id="post-18611" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/mike-flynn-offers-testify-exchange-immunity-dioxin-poisoning/" title="Mike Flynn offers to testify in exchange for immunity to dioxin poisoning">
			            <img src="/wp-content/uploads/2017/03/Michael-Flynn-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/mike-flynn-offers-testify-exchange-immunity-dioxin-poisoning/" title="Mike Flynn offers to testify in exchange for immunity to dioxin poisoning">Mike Flynn offers to testify in exchange for immunity to dioxin poisoning</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18550 type-post status-publish format-standard has-post-thumbnail hentry category-us tag-animatronic tag-disney tag-disney-world tag-donald-trump tag-florida tag-hall-of-presidents tag-magic-kingdom tag-orlando tag-president tag-robot tag-trump" id="post-18550" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/disneys-animatronic-trump-tragically-seems-understand/" title="Disney&#8217;s animatronic Trump tragically seems to understand what it is">
			            <img src="/wp-content/uploads/2017/03/TRUMP-Hall-of-presidents-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/disneys-animatronic-trump-tragically-seems-understand/" title="Disney&#8217;s animatronic Trump tragically seems to understand what it is">Disney&#8217;s animatronic Trump tragically seems to understand what it is</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-16957 type-post status-publish format-video has-post-thumbnail hentry category-beavfeed category-historical-archives tag-featured-post tag-history post_format-post-format-video" id="post-16957" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/01/canadians-learn-gandhi-serial-killer-gilles-de-rais/" title="Canadians Learn About Gandhi and Serial Killer Gilles de Rais">
			            <img src="/wp-content/uploads/2017/01/ghandi-1-240x150.png" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/01/canadians-learn-gandhi-serial-killer-gilles-de-rais/" title="Canadians Learn About Gandhi and Serial Killer Gilles de Rais">Canadians Learn About Gandhi and Serial Killer Gilles de Rais</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-3958 type-post status-publish format-standard has-post-thumbnail hentry category-historical-archives tag-hockey tag-jean-ratelle tag-maple-leaf-gardens tag-montreal-forum tag-moscow tag-paul-henderson tag-phil-esposito tag-soviet-union tag-summit-series tag-team-canada" id="post-3958" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2015/09/september-28-1972-paul-henderson-s-goal-causes-world-war-iii/" title="September 28, 1972: Paul Henderson&#8217;s goal causes World War III">
			            <img src="/wp-content/uploads/2015/09/Miracle-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2015/09/september-28-1972-paul-henderson-s-goal-causes-world-war-iii/" title="September 28, 1972: Paul Henderson&#8217;s goal causes World War III">September 28, 1972: Paul Henderson&#8217;s goal causes World War III</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-3761 type-post status-publish format-standard has-post-thumbnail hentry category-historical-archives tag-avro-arrow tag-chevrolet tag-john-diefenbaker tag-united-states" id="post-3761" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2015/08/diefenbaker-cancels-arrow-program-after-discovering-aircraft-lacks-cupholder/" title="Diefenbaker cancels Arrow program after discovering aircraft lacks cupholder">
			            <img src="/wp-content/uploads/2015/08/Arrow-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2015/08/diefenbaker-cancels-arrow-program-after-discovering-aircraft-lacks-cupholder/" title="Diefenbaker cancels Arrow program after discovering aircraft lacks cupholder">Diefenbaker cancels Arrow program after discovering aircraft lacks cupholder</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-3001 type-post status-publish format-standard has-post-thumbnail hentry category-historical-archives tag-flq tag-french tag-grammar tag-montreal" id="post-3001" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/10/october-20-1970-flq-cell-requires-bescherelle-to-write-this-week-s-ransom-note/" title="October 20, 1970: FLQ cell requires Bescherelle to write this week’s ransom note">
			            <img src="/wp-content/uploads/2014/10/Bescherelle-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/10/october-20-1970-flq-cell-requires-bescherelle-to-write-this-week-s-ransom-note/" title="October 20, 1970: FLQ cell requires Bescherelle to write this week’s ransom note">October 20, 1970: FLQ cell requires Bescherelle to write this week’s ransom note</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5915 menu-item-mega-parent"><a href="https://www.thebeaverton.com/sports/">Sports</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11006"><a href="https://www.thebeaverton.com/news/sports/"><i class="fa fa-arrow-circle-o-right"></i> Sports</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18954 type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-bandwagon tag-blue-jays" id="post-18954" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/burned-abandoned-blue-jay-bandwagon-found-side-401/" title="Burned out, abandoned Blue Jays bandwagon found on side of 401">
			            <img src="/wp-content/uploads/2017/04/Bandwagon-Burned-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/burned-abandoned-blue-jay-bandwagon-found-side-401/" title="Burned out, abandoned Blue Jays bandwagon found on side of 401">Burned out, abandoned Blue Jays bandwagon found on side of 401</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18879 type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-leafs tag-maple-leafs tag-mats-sundin tag-mccain" id="post-18879" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/leafs-playoff-berth-gives-hope-man-also-sucked-decades/" title="Leafs playoff berth gives hope to man who has also sucked for decades">
			            <img src="/wp-content/uploads/2017/04/Leafs-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/leafs-playoff-berth-gives-hope-man-also-sucked-decades/" title="Leafs playoff berth gives hope to man who has also sucked for decades">Leafs playoff berth gives hope to man who has also sucked for decades</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18853 type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-blue-jays tag-rogers tag-rogers-centre tag-skydome tag-ted-rogers" id="post-18853" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/rogers-centre-unveils-new-ted-rogers-statue-right-field/" title="Rogers Centre unveils new Ted Rogers statue in right field">
			            <img src="/wp-content/uploads/2017/04/Ted-Rogers-statue-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/rogers-centre-unveils-new-ted-rogers-statue-right-field/" title="Rogers Centre unveils new Ted Rogers statue in right field">Rogers Centre unveils new Ted Rogers statue in right field</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18700 type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-bobsled tag-hockey tag-luge tag-olympics tag-penguins tag-sidney-crosby" id="post-18700" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/sidney-crosby-now-training-luge/" title="Sidney Crosby now training for luge">
			            <img src="/wp-content/uploads/2017/04/Sidney-Crosby-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/sidney-crosby-now-training-luge/" title="Sidney Crosby now training for luge">Sidney Crosby now training for luge</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5866 menu-item-mega-parent"><a href="https://www.thebeaverton.com/news/business/">Business</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11309"><a href="https://www.thebeaverton.com/news/business/"><i class="fa fa-arrow-circle-o-right"></i> Business</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19023 type-post status-publish format-standard has-post-thumbnail hentry category-business tag-apple tag-laptop tag-macbook tag-porn tag-torrent" id="post-19023" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/apple-invents-new-laptop-designed-turned-off/" title="Apple invents new laptop that is designed to be turned off once in a while">
			            <img src="/wp-content/uploads/2017/04/Macbook-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/apple-invents-new-laptop-designed-turned-off/" title="Apple invents new laptop that is designed to be turned off once in a while">Apple invents new laptop that is designed to be turned off once in a while</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18987 type-post status-publish format-standard has-post-thumbnail hentry category-business tag-chicken-wings tag-grill tag-special tag-sports-bar tag-tim-hortons" id="post-18987" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/legal-action-forces-restaurant-rebrand-deathly-hot-wings-diarrhea-wings/" title="Legal action forces restaurant to rebrand deathly hot wings as diarrhea wings">
			            <img src="/wp-content/uploads/2017/04/Wings-1-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/legal-action-forces-restaurant-rebrand-deathly-hot-wings-diarrhea-wings/" title="Legal action forces restaurant to rebrand deathly hot wings as diarrhea wings">Legal action forces restaurant to rebrand deathly hot wings as diarrhea wings</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18856 type-post status-publish format-standard has-post-thumbnail hentry category-business tag-cookies tag-dare tag-girl-guides" id="post-18856" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/major-cookie-conglomerate-expects-record-sales-thanks-child-labour-initiative/" title="Major cookie conglomerate expects record sales thanks to child labour initiative">
			            <img src="/wp-content/uploads/2017/04/Girl-Guide-Cookies-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/major-cookie-conglomerate-expects-record-sales-thanks-child-labour-initiative/" title="Major cookie conglomerate expects record sales thanks to child labour initiative">Major cookie conglomerate expects record sales thanks to child labour initiative</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18240 type-post status-publish format-standard has-post-thumbnail hentry category-business tag-fraud tag-td-bank" id="post-18240" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/td-offering-account-insurance-protect-td-related-fraud/" title="TD offering account insurance to protect against TD-related fraud">
			            <img src="/wp-content/uploads/2017/03/TD-Bank-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/td-offering-account-insurance-protect-td-related-fraud/" title="TD offering account insurance to protect against TD-related fraud">TD offering account insurance to protect against TD-related fraud</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10989 menu-item-mega-parent"><a href="https://www.thebeaverton.com/news/culture/">Culture</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11008"><a href="https://www.thebeaverton.com/news/culture/"><i class="fa fa-arrow-circle-o-right"></i> Culture</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10990"><a href="https://www.thebeaverton.com/news/comics/"><i class="fa fa-arrow-circle-o-right"></i> Comics</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18982 type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-bill-oreilly tag-donald-trump tag-fox-news tag-roger-ailes tag-rupert-murdoch tag-sean-hannity tag-sexual-harassment tag-tucker-carlson" id="post-18982" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/fox-news-limits-hosts-5-sexual-harassment-scandal-maximum/" title="Fox News limits hosts to 5 sexual harassment scandal maximum">
			            <img src="/wp-content/uploads/2017/04/5035139939_42994f5df3_b-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/fox-news-limits-hosts-5-sexual-harassment-scandal-maximum/" title="Fox News limits hosts to 5 sexual harassment scandal maximum">Fox News limits hosts to 5 sexual harassment scandal maximum</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18978 type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-canadian-film-day tag-don-cherry tag-kim-catrall tag-porkys tag-vcr" id="post-18978" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/dust-blown-off-porkys-tapes-coast-coast-nation-celebrates-canadian-film-day/" title="Dust blown off Porky&#8217;s tapes from coast to coast as nation celebrates Canadian Film Day">
			            <img src="/wp-content/uploads/2017/04/Porkys-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/dust-blown-off-porkys-tapes-coast-coast-nation-celebrates-canadian-film-day/" title="Dust blown off Porky&#8217;s tapes from coast to coast as nation celebrates Canadian Film Day">Dust blown off Porky&#8217;s tapes from coast to coast as nation celebrates Canadian Film Day</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18964 type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-affair tag-iron-fist tag-netflix" id="post-18964" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/wifes-affair-gives-husband-time-finally-catch-netflix-queue/" title="Wife&#8217;s affair gives husband time to finally catch up on Netflix queue">
			            <img src="/wp-content/uploads/2017/04/Depositphotos_40849161_s-2015-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/wifes-affair-gives-husband-time-finally-catch-netflix-queue/" title="Wife&#8217;s affair gives husband time to finally catch up on Netflix queue">Wife&#8217;s affair gives husband time to finally catch up on Netflix queue</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18915 type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-coachella tag-donald-trump tag-drake tag-festival tag-hologram tag-indio tag-tegan-and-sara tag-trump tag-united-states" id="post-18915" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/coachella-fans-really-bummed-new-trump-hologram-looming-entire-festival/" title="Coachella fans really bummed this new Trump hologram is looming over the entire festival">
			            <img src="/wp-content/uploads/2017/04/Trump-Coachella-2-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/coachella-fans-really-bummed-new-trump-hologram-looming-entire-festival/" title="Coachella fans really bummed this new Trump hologram is looming over the entire festival">Coachella fans really bummed this new Trump hologram is looming over the entire festival</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-445 type-post status-publish format-image has-post-thumbnail hentry category-comics tag-stephennotley post_format-image" id="post-445" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2011/07/bob-the-angry-flower-press-this/" title="Bob the Angry Flower: Press This">
			            <img src="/wp-content/uploads/ca332973fc363da77aefed58534dcd5c.jpg" width="118" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2011/07/bob-the-angry-flower-press-this/" title="Bob the Angry Flower: Press This">Bob the Angry Flower: Press This</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-326 type-post status-publish format-image has-post-thumbnail hentry category-comics tag-stephennotley post_format-image" id="post-326" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2011/02/bob-the-angry-flower-revolt/" title="Bob the Angry Flower: Revolt">
			            <img src="/wp-content/uploads/464131a32be92db1eb03bd70266fdd38.jpg" width="117" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2011/02/bob-the-angry-flower-revolt/" title="Bob the Angry Flower: Revolt">Bob the Angry Flower: Revolt</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-308 type-post status-publish format-image has-post-thumbnail hentry category-comics tag-bob-the-angry-flower tag-stephennotley post_format-image" id="post-308" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2011/01/bob-the-angry-flower-rhetorical/" title="Bob the Angry Flower: Rhetorical">
			            <img src="/wp-content/uploads/52ec984cc72302fd412e2aa145a6526c.jpg" width="118" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2011/01/bob-the-angry-flower-rhetorical/" title="Bob the Angry Flower: Rhetorical">Bob the Angry Flower: Rhetorical</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-293 type-post status-publish format-image has-post-thumbnail hentry category-comics tag-bob-the-angry-flower tag-stephennotley post_format-image" id="post-293" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2010/12/bob-the-angry-flower-bank-job/" title="Bob the Angry Flower: Bank Job">
			            <img src="/wp-content/uploads/dc9e231f652301f80ea8e901bd9ec18a.jpg" width="116" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2010/12/bob-the-angry-flower-bank-job/" title="Bob the Angry Flower: Bank Job">Bob the Angry Flower: Bank Job</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10991 menu-item-mega-parent"><a href="https://www.thebeaverton.com/news/lifestyle/">Lifestyle</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11009"><a href="https://www.thebeaverton.com/news/lifestyle/"><i class="fa fa-arrow-circle-o-right"></i> Lifestyle</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10993"><a href="https://www.thebeaverton.com/news/health/"><i class="fa fa-arrow-circle-o-right"></i> Health</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10997"><a href="https://www.thebeaverton.com/news/opinion/"><i class="fa fa-arrow-circle-o-right"></i> Opinion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10998"><a href="https://www.thebeaverton.com/news/stats/"><i class="fa fa-arrow-circle-o-right"></i> Stats</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10992"><a href="https://www.thebeaverton.com/news/classifieds/"><i class="fa fa-arrow-circle-o-right"></i> Classifieds</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10995"><a href="https://www.thebeaverton.com/news/krysten/"><i class="fa fa-arrow-circle-o-right"></i> Krysten</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10996"><a href="https://www.thebeaverton.com/news/lifestyle/magazine/"><i class="fa fa-arrow-circle-o-right"></i> Magazine</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18810 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-lifestyle tag-bridge tag-death tag-invite tag-kill tag-list tag-marriage tag-murder tag-plan tag-planning tag-relatives tag-throw tag-wedding" id="post-18810" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/inspiring-woman-cuts-wedding-guest-list-half-throwing-relatives-off-bridge/" title="Inspiring! Woman cuts wedding guest list in half by throwing her relatives off of a bridge">
			            <img src="/wp-content/uploads/2017/04/pexels-photo-265714-240x150.jpeg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/inspiring-woman-cuts-wedding-guest-list-half-throwing-relatives-off-bridge/" title="Inspiring! Woman cuts wedding guest list in half by throwing her relatives off of a bridge">Inspiring! Woman cuts wedding guest list in half by throwing her relatives off of a bridge</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18524 type-post status-publish format-standard has-post-thumbnail hentry category-lifestyle tag-cleaning tag-illusion tag-make-love tag-teamwork" id="post-18524" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/frantic-cleaning-apartment-arrival-guests-now-quality-time-couple-spends-together/" title="Frantic cleaning of apartment before arrival of guests only quality time couple spends together">
			            <img src="/wp-content/uploads/2017/03/Couple-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/frantic-cleaning-apartment-arrival-guests-now-quality-time-couple-spends-together/" title="Frantic cleaning of apartment before arrival of guests only quality time couple spends together">Frantic cleaning of apartment before arrival of guests only quality time couple spends together</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17883 type-post status-publish format-standard has-post-thumbnail hentry category-lifestyle tag-cruise tag-fun-tivities tag-magician tag-regret" id="post-17883" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/entire-family-unsure-actually-wanted-go-cruise/" title="Entire family unsure who actually wanted to go on cruise">
			            <img src="/wp-content/uploads/2017/02/Cruise-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/entire-family-unsure-actually-wanted-go-cruise/" title="Entire family unsure who actually wanted to go on cruise">Entire family unsure who actually wanted to go on cruise</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17868 type-post status-publish format-standard has-post-thumbnail hentry category-lifestyle tag-family-day" id="post-17868" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/02/5-ways-abandon-kids-family-day/" title="5 ways to abandon your kids on Family Day">
			            <img src="/wp-content/uploads/2017/02/Family-of-Five-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/02/5-ways-abandon-kids-family-day/" title="5 ways to abandon your kids on Family Day">5 ways to abandon your kids on Family Day</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19009 type-post status-publish format-standard has-post-thumbnail hentry category-health tag-cigarettes tag-consumer-of-flesh tag-gorthax tag-heart-disease tag-lifestyle tag-obesity tag-sedentary" id="post-19009" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/study-drop-world-life-expectancy-attributable-rising-obesity-gorthax-hypergalactic-space-cannibal/" title="Study: Drop in world life expectancy attributable to rising obesity, Gorthax the Hypergalactic Space Cannibal">
			            <img src="/wp-content/uploads/2017/04/Gorthax-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/study-drop-world-life-expectancy-attributable-rising-obesity-gorthax-hypergalactic-space-cannibal/" title="Study: Drop in world life expectancy attributable to rising obesity, Gorthax the Hypergalactic Space Cannibal">Study: Drop in world life expectancy attributable to rising obesity, Gorthax the Hypergalactic Space Cannibal</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18813 type-post status-publish format-standard has-post-thumbnail hentry category-health tag-cleanse tag-meditation tag-mindfulness tag-yoga" id="post-18813" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/man-researching-meditation-really-going-something-right-now/" title="Man researching meditation really going through something right now">
			            <img src="/wp-content/uploads/2017/04/Local-man-profile-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/man-researching-meditation-really-going-something-right-now/" title="Man researching meditation really going through something right now">Man researching meditation really going through something right now</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18806 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-health tag-aging tag-amputate tag-beauty tag-cellulite tag-cosmetics tag-knife tag-legs tag-procedure tag-removed tag-secret tag-surgery tag-weight-loss tag-x-acto-knife" id="post-18806" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/beauty-secret-number-one-trick-ridding-cellulite-remove-legs/" title="BEAUTY SECRET: The number one trick to ridding cellulite &#8211; remove legs!">
			            <img src="/wp-content/uploads/2017/04/cellulite-remove-legs-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/beauty-secret-number-one-trick-ridding-cellulite-remove-legs/" title="BEAUTY SECRET: The number one trick to ridding cellulite &#8211; remove legs!">BEAUTY SECRET: The number one trick to ridding cellulite &#8211; remove legs!</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18527 type-post status-publish format-standard has-post-thumbnail hentry category-health tag-elite tag-elites tag-pharmacist tag-pharmacists tag-pharmacy tag-prescription tag-shoppers-drug-mart tag-squad tag-super" id="post-18527" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/breaking-elite-squad-super-pharmacists-fills-prescription-just-90-minutes/" title="BREAKING: Elite squad of super pharmacists fills prescription in just 90 minutes">
			            <img src="/wp-content/uploads/2017/03/Elite-Super-Pharmacists-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/breaking-elite-squad-super-pharmacists-fills-prescription-just-90-minutes/" title="BREAKING: Elite squad of super pharmacists fills prescription in just 90 minutes">BREAKING: Elite squad of super pharmacists fills prescription in just 90 minutes</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19012 type-post status-publish format-standard has-post-thumbnail hentry category-editorial tag-blm tag-pride tag-pride-toronto tag-toronto-police" id="post-19012" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/blm-vs-police-debate-taking-away-true-meaning-toronto-pride-corporate-sponsorship/" title="BLM vs police debate is taking away from the true meaning of Toronto Pride: corporate sponsorship">
			            <img src="/wp-content/uploads/2017/04/Pride-Corporate-Sponsorship-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/blm-vs-police-debate-taking-away-true-meaning-toronto-pride-corporate-sponsorship/" title="BLM vs police debate is taking away from the true meaning of Toronto Pride: corporate sponsorship">BLM vs police debate is taking away from the true meaning of Toronto Pride: corporate sponsorship</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18958 type-post status-publish format-standard has-post-thumbnail hentry category-editorial tag-child tag-children tag-giraffe tag-parenting" id="post-18958" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/children-helps-cope-fact-will-never-giraffe/" title="Having children helps me cope with the fact I will never own a giraffe">
			            <img src="/wp-content/uploads/2017/04/pexels-photo-251829-240x150.jpeg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/children-helps-cope-fact-will-never-giraffe/" title="Having children helps me cope with the fact I will never own a giraffe">Having children helps me cope with the fact I will never own a giraffe</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18824 type-post status-publish format-standard has-post-thumbnail hentry category-editorial tag-aunt-pam tag-christianity tag-egypt tag-jesus tag-jewish tag-passover" id="post-18824" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/just-heads-invited-something-called-passover-year/" title="Just a heads up that we’re being invited to something called “Passover” this year">
			            <img src="/wp-content/uploads/2017/04/Aunt-Pam-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/just-heads-invited-something-called-passover-year/" title="Just a heads up that we’re being invited to something called “Passover” this year">Just a heads up that we’re being invited to something called “Passover” this year</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18791 type-post status-publish format-standard has-post-thumbnail hentry category-editorial tag-cia tag-donald-j-trump tag-donald-trump tag-election tag-eric-trump tag-fbi tag-government tag-hack tag-hackers tag-jeff-sessions tag-michael-flynn tag-nsa tag-paul-manafort tag-president tag-president-trump tag-rex-tillerson tag-russia tag-russians tag-sergei-kislyak tag-trump tag-trump-tower tag-white-house" id="post-18791" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/editorial-eric-trump-russia-compromise-everyone/" title="EDITORIAL by Eric Trump: “Why did Russia compromise everyone but me?”">
			            <img src="/wp-content/uploads/2017/04/Eric-Trump-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/editorial-eric-trump-russia-compromise-everyone/" title="EDITORIAL by Eric Trump: “Why did Russia compromise everyone but me?”">EDITORIAL by Eric Trump: “Why did Russia compromise everyone but me?”</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2130 type-post status-publish format-standard has-post-thumbnail hentry category-stats tag-federal-budget tag-veterans" id="post-2130" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/02/2014-canadian-federal-budget-preview/" title="2014 Canadian Federal Budget Preview">
			            <img src="/wp-content/uploads/2014/02/2014Budget-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/02/2014-canadian-federal-budget-preview/" title="2014 Canadian Federal Budget Preview">2014 Canadian Federal Budget Preview</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2033 type-post status-publish format-standard has-post-thumbnail hentry category-stats tag-boardwalk-empire tag-coffee tag-nelson-mandela tag-nobel-prize tag-ryan-gosling" id="post-2033" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/01/most-frequent-online-dating-profile-lies/" title="Most frequent lies found on online dating profiles">
			            <img src="/wp-content/uploads/2014/01/ManComputer-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/01/most-frequent-online-dating-profile-lies/" title="Most frequent lies found on online dating profiles">Most frequent lies found on online dating profiles</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-1819 type-post status-publish format-standard has-post-thumbnail hentry category-stats tag-halloween" id="post-1819" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2013/10/what-are-you-dressing-up-as-for-halloween/" title="What are you dressing up as for Halloween?">
			            <img src="/wp-content/uploads/2013/10/HalloweenStats-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2013/10/what-are-you-dressing-up-as-for-halloween/" title="What are you dressing up as for Halloween?">What are you dressing up as for Halloween?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-1517 type-post status-publish format-standard has-post-thumbnail hentry category-stats tag-mps tag-senate" id="post-1517" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2013/08/senator-and-mp-expense-claims-2012/" title="Senator and MP Expense Claims 2012">
			            <img src="/wp-content/uploads/2013/08/Senator-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2013/08/senator-and-mp-expense-claims-2012/" title="Senator and MP Expense Claims 2012">Senator and MP Expense Claims 2012</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-238 type-post status-publish format-image hentry category-for-sale post_format-post-format-image" id="post-238" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2010/11/lots-of-jars-full-of-apricot-pits/" title="LOTS OF JARS FULL OF APRICOT PITS.">
			            <img src="" width="" height="" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2010/11/lots-of-jars-full-of-apricot-pits/" title="LOTS OF JARS FULL OF APRICOT PITS.">LOTS OF JARS FULL OF APRICOT PITS.</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-227 type-post status-publish format-image hentry category-help-wanted post_format-post-format-image" id="post-227" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2010/11/essay-writes-needed-asap-big-money/" title="ESSAY WRITERS NEEDED ASAP. BIG MONEY $$$$$.">
			            <img src="" width="" height="" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2010/11/essay-writes-needed-asap-big-money/" title="ESSAY WRITERS NEEDED ASAP. BIG MONEY $$$$$.">ESSAY WRITERS NEEDED ASAP. BIG MONEY $$$$$.</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-180 type-post status-publish format-image hentry category-wanted tag-university post_format-post-format-image" id="post-180" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2010/07/university-student-seeking-mannequin-to-come-alive-and-be-my-girlfriend/" title="UNIVERSITY student seeking mannequin to come alive and be my girlfriend.">
			            <img src="" width="" height="" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2010/07/university-student-seeking-mannequin-to-come-alive-and-be-my-girlfriend/" title="UNIVERSITY student seeking mannequin to come alive and be my girlfriend.">UNIVERSITY student seeking mannequin to come alive and be my girlfriend.</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2827 type-post status-publish format-standard has-post-thumbnail hentry category-magazine tag-feminism" id="post-2827" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/08/is-it-time-for-canada-to-legalize-women/" title="Is it time for Canada to legalize women?">
			            <img src="/wp-content/uploads/2014/08/LegalizeWomen-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/08/is-it-time-for-canada-to-legalize-women/" title="Is it time for Canada to legalize women?">Is it time for Canada to legalize women?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-2811 type-post status-publish format-standard has-post-thumbnail hentry category-magazine tag-syria" id="post-2811" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2014/08/syria-is-it-still-a-thing/" title="SYRIA: Is it still a thing?">
			            <img src="/wp-content/uploads/2014/08/SyriaMagazine-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2014/08/syria-is-it-still-a-thing/" title="SYRIA: Is it still a thing?">SYRIA: Is it still a thing?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-1864 type-post status-publish format-image has-post-thumbnail hentry category-magazine post_format-post-format-image" id="post-1864" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2013/11/have-you-seen-my-keys/" title="Have you seen my keys?">
			            <img src="/wp-content/uploads/2013/11/96bf577e2682bc7925dad067c2022909_XL-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2013/11/have-you-seen-my-keys/" title="Have you seen my keys?">Have you seen my keys?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-1562 type-post status-publish format-standard has-post-thumbnail hentry category-magazine" id="post-1562" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2013/08/7-tips-to-prevent-your-house-from-smelling-like-shit/" title="7 tips to prevent your house from smelling like shit">
			            <img src="/wp-content/uploads/2013/08/MagazineHouseSmell-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2013/08/7-tips-to-prevent-your-house-from-smelling-like-shit/" title="7 tips to prevent your house from smelling like shit">7 tips to prevent your house from smelling like shit</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5884 menu-item-mega-parent"><a href="https://www.thebeaverton.com/beavfeed/">BeavFeed</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11310"><a href="https://www.thebeaverton.com/news/beavfeed/"><i class="fa fa-arrow-circle-o-right"></i> Beavfeed</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10975"><a href="https://www.thebeaverton.com/news/choice-your-own-adventure/"><i class="fa fa-arrow-circle-o-right"></i> Choice Your Own Adventure</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10977"><a href="https://www.thebeaverton.com/news/quiz/"><i class="fa fa-arrow-circle-o-right"></i> Quiz</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10978"><a href="https://www.thebeaverton.com/news/slideshow/"><i class="fa fa-arrow-circle-o-right"></i> Slideshow</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15825"><a href="https://www.thebeaverton.com/news/guide-to/"><i class="fa fa-arrow-circle-o-right"></i> Guide To/How To</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18991 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed tag-amazing tag-angry tag-facebook tag-incredible tag-internet tag-mad tag-man tag-troll tag-twitter tag-wow" id="post-18991" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/amazing-man-mad/" title="Amazing! Man mad!">
			            <img src="/wp-content/uploads/2017/04/Depositphotos_45101179_m-2015-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/amazing-man-mad/" title="Amazing! Man mad!">Amazing! Man mad!</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18951 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-quiz tag-coffee tag-fast-food" id="post-18951" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/quiz-disappointingly-bland-tim-hortons-food-item/" title="Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?">
			            <img src="/wp-content/uploads/2017/04/iStock-464370247-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/quiz-disappointingly-bland-tim-hortons-food-item/" title="Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?">Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18933 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed tag-history tag-social-media tag-twitter tag-world-war-ii" id="post-18933" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/inspiring-read-tweets-brought-mussolini/" title="Inspiring! Read the tweets that brought down Mussolini">
			            <img src="/wp-content/uploads/2017/04/FeaturedMussolini-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/inspiring-read-tweets-brought-mussolini/" title="Inspiring! Read the tweets that brought down Mussolini">Inspiring! Read the tweets that brought down Mussolini</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18838 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-quiz tag-mental-health tag-technology" id="post-18838" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/quiz-obsessive-person-click-lot-boxes-find/" title="Quiz &#8211;  Are you an obsessive person? Click a lot of boxes to find out!">
			            <img src="/wp-content/uploads/2017/04/iStock-525587825-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/quiz-obsessive-person-click-lot-boxes-find/" title="Quiz &#8211;  Are you an obsessive person? Click a lot of boxes to find out!">Quiz &#8211;  Are you an obsessive person? Click a lot of boxes to find out!</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18702 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-choice-your-own-adventure tag-ago tag-art tag-art-gallery-of-ontario tag-crime tag-toronto-2" id="post-18702" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/just-lit-off-bunch-fireworks-realizing-art-gallery-ontario-can-save-priceless-pieces-art/" title="You just lit off a bunch of fireworks before realizing you were in the Art Gallery of Ontario. Can you save the priceless pieces of art?">
			            <img src="/wp-content/uploads/2017/04/featured-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/just-lit-off-bunch-fireworks-realizing-art-gallery-ontario-can-save-priceless-pieces-art/" title="You just lit off a bunch of fireworks before realizing you were in the Art Gallery of Ontario. Can you save the priceless pieces of art?">You just lit off a bunch of fireworks before realizing you were in the Art Gallery of Ontario. Can you save the priceless pieces of art?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18204 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-choice-your-own-adventure tag-architecture tag-family tag-insect tag-police" id="post-18204" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/magically-turned-bug-can-live-happy-fulfilling-life/" title="You magically turned into a bug! Can you live a happy and fulfilling life?">
			            <img src="/wp-content/uploads/2017/03/pexels-photo-13886-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/magically-turned-bug-can-live-happy-fulfilling-life/" title="You magically turned into a bug! Can you live a happy and fulfilling life?">You magically turned into a bug! Can you live a happy and fulfilling life?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-17300 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-choice-your-own-adventure tag-nazis tag-racism tag-trump tag-violence" id="post-17300" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/01/chance-punch-nazi-take/" title="You have a chance to punch a Nazi. Do you take it?">
			            <img src="/wp-content/uploads/2017/01/iStock-181900732-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/01/chance-punch-nazi-take/" title="You have a chance to punch a Nazi. Do you take it?">You have a chance to punch a Nazi. Do you take it?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-15712 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-choice-your-own-adventure tag-donald-trump tag-racism" id="post-15712" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2016/11/just-said-something-unintentionally-racist-can-get/" title="You just said something unintentionally racist. Can you get out of it?">
			            <img src="/wp-content/uploads/2016/11/iStock_73509337_SMALL-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2016/11/just-said-something-unintentionally-racist-can-get/" title="You just said something unintentionally racist. Can you get out of it?">You just said something unintentionally racist. Can you get out of it?</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18951 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-quiz tag-coffee tag-fast-food" id="post-18951" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/quiz-disappointingly-bland-tim-hortons-food-item/" title="Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?">
			            <img src="/wp-content/uploads/2017/04/iStock-464370247-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/quiz-disappointingly-bland-tim-hortons-food-item/" title="Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?">Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18838 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-quiz tag-mental-health tag-technology" id="post-18838" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/quiz-obsessive-person-click-lot-boxes-find/" title="Quiz &#8211;  Are you an obsessive person? Click a lot of boxes to find out!">
			            <img src="/wp-content/uploads/2017/04/iStock-525587825-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/quiz-obsessive-person-click-lot-boxes-find/" title="Quiz &#8211;  Are you an obsessive person? Click a lot of boxes to find out!">Quiz &#8211;  Are you an obsessive person? Click a lot of boxes to find out!</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18804 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-quiz tag-aunt tag-business tag-cool tag-infertile-aunt tag-lame tag-mom tag-moms tag-mother tag-mothers tag-quiz" id="post-18804" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/quiz-cool-mom-business-mom-lame-mom-infertile-aunt/" title="QUIZ: Are you a Cool Mom, Business Mom, Lame Mom or Infertile Aunt?">
			            <img src="/wp-content/uploads/2017/04/mother-daughter-love-sunset-51953-240x150.jpeg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/quiz-cool-mom-business-mom-lame-mom-infertile-aunt/" title="QUIZ: Are you a Cool Mom, Business Mom, Lame Mom or Infertile Aunt?">QUIZ: Are you a Cool Mom, Business Mom, Lame Mom or Infertile Aunt?</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18455 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-quiz tag-anne-of-green-gables tag-film tag-literature tag-pop-culture tag-prince-edward-island tag-television" id="post-18455" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/quiz-anne-green-gables/" title="QUIZ: Which Anne of Green Gables are you?">
			            <img src="/wp-content/uploads/2017/03/Montgomery_Anne_of_Green_Gables-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/quiz-anne-green-gables/" title="QUIZ: Which Anne of Green Gables are you?">QUIZ: Which Anne of Green Gables are you?</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18627 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-slideshow" id="post-18627" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/7-women-whose-brazen-sexuality-find-unsettling/" title="7 women whose brazen sexuality we find unsettling">
			            <img src="/wp-content/uploads/2016/08/Depositphotos_110577802_s-2015-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/7-women-whose-brazen-sexuality-find-unsettling/" title="7 women whose brazen sexuality we find unsettling">7 women whose brazen sexuality we find unsettling</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-16624 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-slideshow tag-family tag-holidays tag-juice tag-raw" id="post-16624" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2016/12/6-juices-raw-holiday-family-interactions/" title="6 juices as raw as your holiday family interactions">
			            <img src="/wp-content/uploads/2016/12/4856222073_125afe086a_z-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2016/12/6-juices-raw-holiday-family-interactions/" title="6 juices as raw as your holiday family interactions">6 juices as raw as your holiday family interactions</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-16543 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-slideshow tag-christmas tag-christmas-carols tag-hanukkah tag-holidays" id="post-16543" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2016/12/5-christmas-songs-jewish-people-love-hearing-non-stop-entire-month/" title="5 Christmas songs Jewish people love hearing non-stop for an entire month">
			            <img src="/wp-content/uploads/2016/08/jingle-bells-1862412_640-240x150.png" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2016/12/5-christmas-songs-jewish-people-love-hearing-non-stop-entire-month/" title="5 Christmas songs Jewish people love hearing non-stop for an entire month">5 Christmas songs Jewish people love hearing non-stop for an entire month</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-16572 type-post status-publish format-standard has-post-thumbnail hentry category-beavfeed category-slideshow tag-cheap-gifts tag-holiday-gifts tag-household-items" id="post-16572" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2016/12/5-household-items-almost-pass-christmas-gifts/" title="5 household items that could almost pass as Christmas gifts">
			            <img src="/wp-content/uploads/2016/12/Holiday-gift-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2016/12/5-household-items-almost-pass-christmas-gifts/" title="5 household items that could almost pass as Christmas gifts">5 household items that could almost pass as Christmas gifts</a></h6>
	</header>
</div></div></div><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19004 type-post status-publish format-video has-post-thumbnail hentry category-guide-to category-video tag-featured-post tag-guide-to post_format-post-format-video" id="post-19004" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/guide-to-the-north/" title="Guide To: The North">
			            <img src="/wp-content/uploads/2017/04/guide-to-the-north-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/guide-to-the-north/" title="Guide To: The North">Guide To: The North</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18850 type-post status-publish format-video has-post-thumbnail hentry category-guide-to category-video tag-featured-post tag-university post_format-post-format-video" id="post-18850" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/survive-finals-week/" title="How To: Survive Finals Week">
			            <img src="/wp-content/uploads/2017/04/how-to-survive-finals-week-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/survive-finals-week/" title="How To: Survive Finals Week">How To: Survive Finals Week</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18464 type-post status-publish format-video has-post-thumbnail hentry category-guide-to category-us category-video tag-guide-to tag-travel tag-usa post_format-post-format-video" id="post-18464" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/guide-travelling-us/" title="Guide To: Travelling To The US">
			            <img src="/wp-content/uploads/2017/03/GuidetoUSTravel-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/guide-travelling-us/" title="Guide To: Travelling To The US">Guide To: Travelling To The US</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18317 type-post status-publish format-video has-post-thumbnail hentry category-guide-to category-video tag-featured-post tag-how-to tag-true-love post_format-post-format-video" id="post-18317" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/03/find-true-love/" title="How To: Find True Love">
			            <img src="/wp-content/uploads/2017/03/Howtofindtruelove-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/03/find-true-love/" title="How To: Find True Love">How To: Find True Love</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12364 menu-item-mega-parent"><a href="https://www.thebeaverton.com/news/video/">Video</a>
<div class="thb_mega_menu_holder"><div class="row"><div class="small-12 columns">

<ul class="sub-menu thb_mega_menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12365"><a href="https://www.thebeaverton.com/news/video/"><i class="fa fa-arrow-circle-o-right"></i> Video</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15920"><a href="http://www.thecomedynetwork.ca/Shows/TheBeaverton"><i class="fa fa-arrow-circle-o-right"></i> Watch the Show!</a></li>
</ul>
<div class="category-children cf"><div class="row "><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-19004 type-post status-publish format-video has-post-thumbnail hentry category-guide-to category-video tag-featured-post tag-guide-to post_format-post-format-video" id="post-19004" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/guide-to-the-north/" title="Guide To: The North">
			            <img src="/wp-content/uploads/2017/04/guide-to-the-north-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/guide-to-the-north/" title="Guide To: The North">Guide To: The North</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18922 type-post status-publish format-video has-post-thumbnail hentry category-video category-world tag-israel tag-middle-east tag-palestine post_format-post-format-video" id="post-18922" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/learn-everything-need-know-israel-palestine-conflict-just-60-seconds/" title="Learn EVERYTHING you need to know about the Israel-Palestine conflict in just 60 seconds">
			            <img src="/wp-content/uploads/2017/04/BV-Israel-Palestine-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/learn-everything-need-know-israel-palestine-conflict-just-60-seconds/" title="Learn EVERYTHING you need to know about the Israel-Palestine conflict in just 60 seconds">Learn EVERYTHING you need to know about the Israel-Palestine conflict in just 60 seconds</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18850 type-post status-publish format-video has-post-thumbnail hentry category-guide-to category-video tag-featured-post tag-university post_format-post-format-video" id="post-18850" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/survive-finals-week/" title="How To: Survive Finals Week">
			            <img src="/wp-content/uploads/2017/04/how-to-survive-finals-week-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/survive-finals-week/" title="How To: Survive Finals Week">How To: Survive Finals Week</a></h6>
	</header>
</div></div><div class="small-12 medium-6 large-3 columns"><div class="post mega-menu-post post-18833 type-post status-publish format-video has-post-thumbnail hentry category-video category-world tag-featured-post tag-north-korea post_format-post-format-video" id="post-18833" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2017/04/wont-believe-going-north-korea-right-now/" title="You WON&#8217;T BELIEVE what is going on in North Korea right now">
			            <img src="/wp-content/uploads/2017/02/bv-plus-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2017/04/wont-believe-going-north-korea-right-now/" title="You WON&#8217;T BELIEVE what is going on in North Korea right now">You WON&#8217;T BELIEVE what is going on in North Korea right now</a></h6>
	</header>
</div></div></div></div></div></div></div></li>
</ul>					</nav>
			</header>
</div>
<!-- End Header -->		<div role="main" class="cf">

<div id="infinite-article" data-infinite="on">
	            
		
<div class="post-detail-row">
    <div class="data_store_quiz_19032">"</div>
    <div class="data_store_video_19032">"</div>
    <div class="data_store_imgcred_19032">http://depositphotos.com/4574171/stock-photo-bedroom-messy-room.html"</div>
    <div class="row">
        <div class="small-12 medium-12 large-8  columns">
			<article itemscope itemtype="http://schema.org/Article" class="post post-detail post-19032 type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-apartment tag-messy tag-student-life tag-university" id="post-19032" role="article" data-id="19032" data-url="https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/">
								<aside class="post-meta cf"><a href="https://www.thebeaverton.com/news/campus/" rel="category tag" class="cat-campus">Campus</a></aside>
								<header class="post-title entry-header">
											<h1 class="entry-title" itemprop="headline">Graduating university student going to miss having excuse to live in own filth</h1>									</header>
				<aside class="post-author">
					<meta itemprop="dateModified" content="2017-04-24T16:39:30+00:00">
					<time class="time" datetime="2017-04-24T18:30:37+00:00" itemprop="datePublished" content="2017-04-24T18:30:37+00:00">3 hours ago</time> <em>by</em> <span itemprop="author"><a href="https://www.thebeaverton.com/author/jacobduarte/" title="Posts by Jacob Duarte Spiel" rel="author">Jacob Duarte Spiel</a></span>
					<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<meta itemprop="name" content="The Beaverton">
						<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
							<meta itemprop="url" content="/wp-content/themes/thevoux-wp_beav/assets/img/logo.png">
						</span>
					</span>
					<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/">
				</aside>
                	<aside class="share-article hide-on-print fixed-me hide-for-small">
				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.thebeaverton.com%2F2017%2F04%2Fgraduating-university-student-going-miss-excuse-live-filth%2F" class="boxed-icon facebook social"><i class="fa fa-facebook"></i></a>
						<a href="https://twitter.com/intent/tweet?text=Graduating+university+student+going+to+miss+having+excuse+to+live+in+own+filth&url=https%3A%2F%2Fwww.thebeaverton.com%2F2017%2F04%2Fgraduating-university-student-going-miss-excuse-live-filth%2F&via=TheBeaverton" class="boxed-icon twitter social "><i class="fa fa-twitter"></i>
            
        </a>
		        
                    <a href="http://pinterest.com/pin/create/link/?url=https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/&amp;media=/wp-content/uploads/2017/04/Depositphotos_4574171_m-2015.jpg" class="boxed-icon pinterest social" data-pin-no-hover="true"><i class="fa fa-pinterest"></i></a>
				            <a href="http://www.reddit.com/submit?url=https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/&title=Graduating university student going to miss having excuse to live in own filth" class="boxed-icon reddit social"><i class="fa fa-reddit"></i></a>
                <a href="https://www.youtube.com/thebeavertontv/" target="_blank" id="watch_episodes_m" class="boxed-icon youtube social"><i class="fa fa-youtube"></i></a>
	</aside>
				<div class="post-content-container">
					                                    <figure class="post-gallery" style="margin: 0 0 25px;" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
                                        <img width="800" height="600" src="/wp-content/uploads/2017/04/Depositphotos_4574171_m-2015-800x600.jpg" class="attachment-thevoux-single size-thevoux-single wp-post-image" alt="" itemprop="url" />                                        <meta itemprop="width" content="800" />
                                        <meta itemprop="height" content="600" />
                                        <div class="featured_image_cred_holder-19032"></div>
                                    </figure>
<!--                              }-->
                                              					<div class="post-content entry-content cf" data-first="M" itemprop="articleBody">
						<p>MONTREAL &#8211; After four years of using his educational status to deflect judgement, Concordia student Navin Singh already misses having a solid excuse to live in his own filth.</p>
<p>“Used to be that when a girl came over I could be like ‘sorry the place is dirty, way too much homework’,” said Singh as he sprayed the 3ft stack of pizza boxes with Windex. “Now what am I supposed to do? Clean? Like a sucker?”</p>
<p>Singh says he now regrets taking for granted such an all-encompassing excuse for his disgusting behaviour.</p>
<p>“I didn’t appreciate the good times because I stupidly assumed they would just last forever,” said Singh, removing a hermit crab from the shower. “Seems like only yesterday I celebrated a No Flush Friday. Where did those halcyon days go?”</p>
<p>Singh, who spent the last six months eating over the sink after the pile of empty bottles totally took over the kitchen table, confirmed that his new <a href="https://www.thebeaverton.com/tag/apartment/" class="st_tag internal_tag" rel="tag" title="Posts tagged with apartment">apartment</a> would probably need to be cleaned more than once a year.</p>
<p>“It’s scary, but I think I’m going to need to change and adapt,” said Singh. “Like that mold that overcame all the other molds to take over the fridge two years ago.”</p>
<p>“Oh god, was that two years ago already?”</p>
<p>At press time, Singh was happily explaining that his apartment was dirty because he couldn’t afford cleaning supplies during his unpaid internship.</p>
						
																														<footer class="article-tags entry-footer">
							<strong>Tags:</strong> 
							<a href="https://www.thebeaverton.com/tag/apartment/" title="">apartment</a>, <a href="https://www.thebeaverton.com/tag/messy/" title="">Messy</a>, <a href="https://www.thebeaverton.com/tag/student-life/" title="">student life</a>, <a href="https://www.thebeaverton.com/tag/university/" title="">university</a>						</footer>
																	</div>
					<div class="cf"></div>
				</div>
					<aside class="share-article hide-on-print show-for-small">
				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.thebeaverton.com%2F2017%2F04%2Fgraduating-university-student-going-miss-excuse-live-filth%2F" class="boxed-icon facebook social"><i class="fa fa-facebook"></i></a>
						<a href="https://twitter.com/intent/tweet?text=Graduating+university+student+going+to+miss+having+excuse+to+live+in+own+filth&url=https%3A%2F%2Fwww.thebeaverton.com%2F2017%2F04%2Fgraduating-university-student-going-miss-excuse-live-filth%2F&via=TheBeaverton" class="boxed-icon twitter social "><i class="fa fa-twitter"></i>
            
        </a>
		        
                    <a href="http://pinterest.com/pin/create/link/?url=https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/&amp;media=/wp-content/uploads/2017/04/Depositphotos_4574171_m-2015.jpg" class="boxed-icon pinterest social" data-pin-no-hover="true"><i class="fa fa-pinterest"></i></a>
				            <a href="http://www.reddit.com/submit?url=https://www.thebeaverton.com/2017/04/graduating-university-student-going-miss-excuse-live-filth/&title=Graduating university student going to miss having excuse to live in own filth" class="boxed-icon reddit social"><i class="fa fa-reddit"></i></a>
                <a href="https://www.youtube.com/thebeavertontv/" target="_blank" id="watch_episodes_m" class="boxed-icon youtube social"><i class="fa fa-youtube"></i></a>
	</aside>
                
                    
			</article>
<!--            <div style="font-size:16px;padding-top:40px;">Watch complete episodes of the Beaverton <a href="http://www.thecomedynetwork.ca/Shows/TheBeaverton" target="_blank">here</a></div>-->
                <div style="font-size:14px;padding-top:40px;">If you enjoyed this, follow us on Facebook: <div class="fb-like" data-href="https://www.facebook.com/TheBeaverton" data-layout="standard" data-action="like" data-size="small" data-show-faces="false" data-share="false"></div>
            
            <!-- Start Related Posts -->
<div class="row post">
	<aside class="small-12 columns post-content related">
		<h4><strong>Related News</strong></h4>
		<div class="row relatedposts hide-on-print" data-equal=">.columns">
		               
		    <div class="small-6 medium-4 columns">
		    	<div class="post mega-menu-post post-4634 type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-benjamin-netanyahu tag-israel tag-mcgill tag-west-bank" id="post-4634" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2016/02/israel-pulls-back-west-bank-settlements-after-mcgill-student-union-bds-vote/" title="Israel pulls back West Bank settlements after McGill student union BDS vote">
			            <img src="/wp-content/uploads/66c7f58622da0e59024b5414de111c30.jpg" width="181" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2016/02/israel-pulls-back-west-bank-settlements-after-mcgill-student-union-bds-vote/" title="Israel pulls back West Bank settlements after McGill student union BDS vote">Israel pulls back West Bank settlements after McGill student union BDS vote</a></h6>
	</header>
</div>		    </div>
		               
		    <div class="small-6 medium-4 columns">
		    	<div class="post mega-menu-post post-16547 type-post status-publish format-standard has-post-thumbnail hentry category-campus category-uncategorized tag-academics tag-allen-sanderson tag-boy tag-cancer tag-economics tag-free-market tag-john-cena tag-make-a-wish tag-milton-friedman tag-professor tag-robert-zimmer tag-tenure tag-university-of-chicago" id="post-16547" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2016/12/make-wish-foundation-fulfills-childs-dream-becoming-tenured-professor-economics/" title="Make-A-Wish foundation fulfills child&#8217;s dream of becoming tenured professor of economics">
			            <img src="/wp-content/uploads/2016/12/cancer-kid-university-of-chicago-240x150.jpg" width="240" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2016/12/make-wish-foundation-fulfills-childs-dream-becoming-tenured-professor-economics/" title="Make-A-Wish foundation fulfills child&#8217;s dream of becoming tenured professor of economics">Make-A-Wish foundation fulfills child&#8217;s dream of becoming tenured professor of economics</a></h6>
	</header>
</div>		    </div>
		               
		    <div class="small-6 medium-4 columns">
		    	<div class="post mega-menu-post post-3602 type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-unemployment tag-windsor" id="post-3602" role="article">
	<figure class="post-gallery">
		<a href="https://www.thebeaverton.com/2015/06/creative-writing-graduate-now-has-skills-to-imagine-job-he-d-be-qualified-for/" title="Creative writing graduate now has skills to imagine job he&#8217;d be qualified for">
			            <img src="/wp-content/uploads/b1f80a786220888292abbd83d8707702.jpg" width="225" height="150" />
		</a>
	</figure>
	<header class="post-title entry-header">
		<h6 itemprop="headline"><a href="https://www.thebeaverton.com/2015/06/creative-writing-graduate-now-has-skills-to-imagine-job-he-d-be-qualified-for/" title="Creative writing graduate now has skills to imagine job he&#8217;d be qualified for">Creative writing graduate now has skills to imagine job he&#8217;d be qualified for</a></h6>
	</header>
</div>		    </div>
		  		</div>
	</aside>
</div>
<!-- End Related Posts -->            
                            <div class="row">
                <div class="comedy_header">
                    <div class="comedy_header_title" style="float:left; padding-top:5px;">WATCH GREAT SHOWS ON COMEDY</div><div class="comedy_logo"><a href="http://www.thecomedynetwork.ca" target="_blank"><img style="float:right; padding-bottom:10px;" src="/wp-content/uploads/2016/11/comedy-related.png" /></a></div> 
                    <hr/>
                </div>
                <div class="comedy_related">
                    <div id="comedy_slider_article_19032">
                      <a href="#!" class="control_next"> > </a>
                      <a href="#!" class="control_prev"> < </a>
                      <ul>
                    <li><div class="cmdy_related_item"><a href="http://www.thecomedynetwork.ca/shows/angietribeca" target="_blank"><img src="http://www.thecomedynetwork.ca/getattachment/8790c984-ecb9-47c0-afbb-d7fa1744f82f?height=130&width=232&crop=True"/><div class="comedy_header_title">Angie Tribeca</div><div class="comedy_header_desc">Monday at 10.30ep</div></a></div><div class="cmdy_related_item"><a href="http://www.thecomedynetwork.ca/shows/dailyshow" target="_blank"><img src="http://www.thecomedynetwork.ca/getattachment/44825d2e-c9a3-4801-8b6b-4c41e7431c42?height=130&width=232&crop=True"/><div class="comedy_header_title">The Daily Show with Trevor Noah</div><div class="comedy_header_desc">Watch Full Episodes</div></a></div><div class="cmdy_related_item"><a href="http://www.thecomedynetwork.cahttp://www.thecomedynetwork.ca/shows/thedetour" target="_blank"><img src="http://www.thecomedynetwork.ca/getattachment/0c8b3026-3bd1-45e0-9584-a09da719f266?height=130&width=232&crop=True"/><div class="comedy_header_title">The Detour</div><div class="comedy_header_desc">Tuesday at 10.30ep</div></a></div></li><li><div class="cmdy_related_item"><a href="http://www.thecomedynetwork.ca/Shows/FullFrontal" target="_blank"><img src="http://www.thecomedynetwork.ca/getattachment/4f0748b7-409f-42a6-8660-271633c5dec2?height=130&width=232&crop=True"/><div class="comedy_header_title">Full Frontal with Samantha Bee</div><div class="comedy_header_desc">Wednesday at 10.30ep</div></a></div><div class="cmdy_related_item"><a href="http://www.thecomedynetwork.cahttp://www.thecomedynetwork.ca/Shows/TheGorburgerShow" target="_blank"><img src="http://www.thecomedynetwork.ca/getattachment/5dad2bfe-40e7-4a1f-8614-bcb09521a5ed?height=130&width=232&crop=True"/><div class="comedy_header_title">The Gorburger Show</div><div class="comedy_header_desc">Sunday at Midnight ep</div></a></div></li>                      </ul>
                  </div>
                </div>
            </div>
            
            <div style="text-align:center;"><img src='/wp-content/themes/thevoux-wp_beav/assets/img/beaver-divider.png'/></div>
		</div>
					
<aside id="article_sidebar_fixed" style="max-width:400px;" class="sidebar small-12 medium-4 columns">
    
	<div class="sidebar_inner" style='padding-top:20px;'>
		<div id="mc4wp_form_widget-8" class="widget cf style2 widget_mc4wp_form_widget"><script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.1.1 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-8946" method="post" data-id="8946" data-name="sidebar" ><div class="mc4wp-form-fields"><div class="social_holder">
  <a href="https://www.facebook.com/TheBeaverton/" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/facebook.png" /></i></a>
  <a href="http://twitter.com/TheBeaverton" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/twitter.png" /></i></a>
  <a href="https://www.youtube.com/channel/UCxraWf1_uR8isJ7S9zfEo5w" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/youtube.png" /></i></a>
  <a href="http://instagram.com/thebeaverton" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/instagram.png" /></i></a>
  <a href="#" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/podcast_s.png" /></i></a>
  <a href="http://www.thebeaverton.com/feed/" class="" target="_blank"><i><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/rss.png" /></i></a>  
</div>
<div class="mailing_list">
<p  class="mail_title">
  Subscribe to our mailing list
  </p>
	<center><input type="email" name="EMAIL" placeholder="name@email.com" size="80" required /> <input type="submit" value="" class="subscribe_btn" /></center>
</div><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1493084163" /><input type="hidden" name="_mc4wp_form_id" value="8946" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></div><div id="st_latest_posts_widget-4" class="widget cf style2 widget_st_latest_posts_widget"><strong><span>Latest Videos</span></strong><div class="latest-posts"><div class="featured_latest_video"><div class="pull-left"><a href="https://www.thebeaverton.com/2017/04/guide-to-the-north/"><img width="300" height="170" src="/wp-content/uploads/2017/04/guide-to-the-north-300x170.jpg" class="img-responsive wp-post-image" alt="" srcset="/wp-content/uploads/2017/04/guide-to-the-north-300x170.jpg 300w, /wp-content/uploads/2017/04/guide-to-the-north-150x85.jpg 150w, /wp-content/uploads/2017/04/guide-to-the-north-768x435.jpg 768w, /wp-content/uploads/2017/04/guide-to-the-north-600x340.jpg 600w, /wp-content/uploads/2017/04/guide-to-the-north.jpg 900w" sizes="(max-width: 300px) 100vw, 300px" /><img src="/wp-content/themes/thevoux-wp_beav/assets/img/play.png" class="play_img" style="width:auto;"/></a></div><div class="media-body"><h3 class="entry-title"><a href="https://www.thebeaverton.com/2017/04/guide-to-the-north/">Guide To: The North</a></h3></div></div><div class="media"><div class="pull-left"><a href="https://www.thebeaverton.com/2017/04/learn-everything-need-know-israel-palestine-conflict-just-60-seconds/"><img width="64" height="64" src="/wp-content/uploads/2017/04/BV-Israel-Palestine-64x64.jpg" class="img-responsive wp-post-image" alt="" /></a></div><div class="media-body"><h3 class="entry-title"><a href="https://www.thebeaverton.com/2017/04/learn-everything-need-know-israel-palestine-conflict-just-60-seconds/">Learn EVERYTHING you need to know about the Israel-Palestine conflict in just 60 seconds</a></h3></div></div><div class="media"><div class="pull-left"><a href="https://www.thebeaverton.com/2017/04/survive-finals-week/"><img width="64" height="64" src="/wp-content/uploads/2017/04/how-to-survive-finals-week-64x64.jpg" class="img-responsive wp-post-image" alt="" /></a></div><div class="media-body"><h3 class="entry-title"><a href="https://www.thebeaverton.com/2017/04/survive-finals-week/">How To: Survive Finals Week</a></h3></div></div><div class="media"><div class="pull-left"><a href="https://www.thebeaverton.com/2017/04/wont-believe-going-north-korea-right-now/"><img width="64" height="64" src="/wp-content/uploads/2017/02/bv-plus-64x64.jpg" class="img-responsive wp-post-image" alt="AJ plus parody" /></a></div><div class="media-body"><h3 class="entry-title"><a href="https://www.thebeaverton.com/2017/04/wont-believe-going-north-korea-right-now/">You WON&#8217;T BELIEVE what is going on in North Korea right now</a></h3></div></div><div class="media"><div class="pull-left"><a href="https://www.thebeaverton.com/2017/04/will-justin-trudeau-handle-wave-refugees-coming-canada-lost-city-atlantis/"><img width="64" height="64" src="/wp-content/uploads/2017/04/BV-plus-atlantis--64x64.jpg" class="img-responsive wp-post-image" alt="AJ Plus Parody" srcset="/wp-content/uploads/2017/04/BV-plus-atlantis--64x64.jpg 64w, /wp-content/uploads/2017/04/BV-plus-atlantis--600x600.jpg 600w" sizes="(max-width: 64px) 100vw, 64px" /></a></div><div class="media-body"><h3 class="entry-title"><a href="https://www.thebeaverton.com/2017/04/will-justin-trudeau-handle-wave-refugees-coming-canada-lost-city-atlantis/">How will Justin Trudeau handle the wave of refugees coming to Canada from the lost city of Atlantis?</a></h3></div></div></div></div><div id="text-9" class="widget cf style2 widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Main Page, Sidebar 2 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:100%;height:250px"
     data-ad-client="ca-pub-6305909245661120"
     data-ad-slot="3276664496"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div>
<!-- WordPress Popular Posts Plugin v3.3.4 [W] [weekly] [views] [regular] -->
<div id="wpp-7" class="widget cf style2 popular-posts">
<strong><span>Most Popular</span></strong>
<ul class="wpp-list">
<li><a href="https://www.thebeaverton.com/2017/04/newfoundland-sunk-collision-iceberg/" title="Newfoundland sunk after collision with iceberg" class="wpp-post-title" target="_self">Newfoundland sunk after collision with iceberg</a><br/><span class="wpp-excerpt">HALIFAX - Four hours after a striking a ...</span></li>
<li><a href="https://www.thebeaverton.com/2015/06/canadian-caught-stealing-american-netflix-to-be-punished-with-3-year-bell-contract/" title="Canadians caught stealing American Netflix to be punished with 3-year Bell contract" class="wpp-post-title" target="_self">Canadians caught stealing American Netflix to be punished with 3-year ...</a><br/><span class="wpp-excerpt">OTTAWA -- At the Canadian Telecom Summit...</span></li>
<li><a href="https://www.thebeaverton.com/2017/04/burned-abandoned-blue-jay-bandwagon-found-side-401/" title="Burned out, abandoned Blue Jays bandwagon found on side of 401" class="wpp-post-title" target="_self">Burned out, abandoned Blue Jays bandwagon found on side of ...</a><br/><span class="wpp-excerpt">COBOURG, ON - Northumberland Ontario Pro...</span></li>
<li><a href="https://www.thebeaverton.com/2015/05/ontario-schoolchildren-our-parents-aren-t-mature-enough-for-us-to-learn-about-sex/" title="Ontario schoolchildren: “Our parents aren’t mature enough for us to learn about sex”" class="wpp-post-title" target="_self">Ontario schoolchildren: “Our parents aren’t mature enough for us to ...</a><br/><span class="wpp-excerpt">TORONTO – Elementary school students acr...</span></li>
<li><a href="https://www.thebeaverton.com/2017/04/quiz-disappointingly-bland-tim-hortons-food-item/" title="Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?" class="wpp-post-title" target="_self">Quiz: What disappointingly bland Tim Horton&#8217;s food item are you?</a><br/><span class="wpp-excerpt">From bagels to donuts to chilli to whate...</span></li>

</ul>
</div>
<!-- End WordPress Popular Posts Plugin v3.3.4 -->
        <a class="twitter-timeline" data-height="400" href="https://twitter.com/TheBeaverton">Tweets by TheBeaverton</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
        <center><a class="twitter-follow-button" href="https://twitter.com/TheBeaverton">Follow @TheBeaverton</a></center>
	</div>
    
</aside>		 	</div>
	</div>	
</div>
		</div><!-- End role["main"] -->
<!--<div id="popup_new" style="display:none;"><div id="popup_container"><a class="close_btn">close</a><br/>Hate website pop-ups? <br/><br/>Well our tv show, airing Wednesdays at 10:00pm ET on Comedy, has almost none!</div></div>-->

	<!-- Start Footer -->
	<!-- Please call pinit.js only once per page -->
	<footer id="footer" role="contentinfo" class="center-align-text ">
        <div class="row no-padding ">
            <div class="footer_holder">
		    <div class="small-12 medium-6 columns">
		    	<div id="text-20" class="widget cf style2 widget_text">			<div class="textwidget"><img width="137" src="/wp-content/uploads/2016/08/new_head.png"/>
<p class="text-center" style="font-size:13px; color: #767676;"">"North America's Trusted Source of News"</p>
<p class="social_holder">
  
  <a href="https://www.facebook.com/TheBeaverton/" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/facebook.png" /></i></a>
  <a href="http://twitter.com/TheBeaverton" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/twitter.png" /></i></a>
  <a href="https://www.youtube.com/channel/UCxraWf1_uR8isJ7S9zfEo5w" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/youtube.png" /></i></a>
  <a href="http://instagram.com/thebeaverton" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/instagram.png" /></i></a>
 <a href="#" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/podcast_s.png" /></i></a>
  

  <a href="http://eepurl.com/18s2v" class="" target="_blank"><i class=""><img class="social_icon" src="/wp-content/themes/thevoux-wp_beav/assets/img/mail.png" /></i></a>
  
</p></div>
		</div>		    </div>
		    <div class="small-12 medium-2 columns">
		    	<div id="nav_menu-3" class="widget cf style2 widget_nav_menu"><strong><span>LEGAL</span></strong><div class="menu-legal-container"><ul id="menu-legal" class="menu"><li id="menu-item-15505" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15505"><a href="https://www.thebeaverton.com/contest/">Contest</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78"><a href="https://www.thebeaverton.com/site-disclaimer/">Disclaimer</a></li>
<li id="menu-item-79" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79"><a href="https://www.thebeaverton.com/terms/">Website Terms and Conditions</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80"><a href="https://www.thebeaverton.com/how-we-use-cookies/">Cookies Policy</a></li>
<li id="menu-item-11751" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11751"><a href="https://www.thebeaverton.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></div>		    </div>
		    <div class="small-12 medium-2 columns">
			    <div id="nav_menu-2" class="widget cf style2 widget_nav_menu"><strong><span>ABOUT</span></strong><div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-15325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15325"><a href="https://www.thebeaverton.com/about-the-show/">About the Show</a></li>
<li id="menu-item-12010" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12010"><a href="https://www.thebeaverton.com/masthead/">Masthead</a></li>
<li id="menu-item-12011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12011"><a href="https://www.thebeaverton.com/content-submission-guidelines/">Content Submission Guidelines</a></li>
</ul></div></div>		    </div>
		    <div class="small-12 medium-2 columns">
			    		    </div>
                </div>
	    </div>
        
        <div class="row" style="background-color:#000;" >
            <div style="width:80%; margin: 0 auto;">
            <section id="sponsors">
                <div class='links'>
                    <a href="http://www.cmf-fmc.ca"><img src="/wp-content/themes/thevoux-wp_beav/assets/img/cmf.gif" /></a>
                    <div><a href="http://www.bellfund.ca"><img class="bellbox" src="/wp-content/themes/thevoux-wp_beav/assets/img/bellfund.png" /></a><div style="font-size:10px;color:#fff;text-align:center;"><a href="bell-fund-waiver" style="color:#fff;">Waiver</a></div></div>
                    <a href="http://www.omdc.on.ca/"><img src="/wp-content/themes/thevoux-wp_beav/assets/img/omdc.png"/></a>
                </div>
            </section>
            </div>
        </div>
		<div class="row" style="background-color:#000;" >
            <div style="width:80%; margin: 0 auto;">
				<div class="copyright">Copyright 2010 - 2016 The Beaverton. All rights reserved.</div>
                <div class="arosa">Arosa Media</div>
            </div>
		</div>
        
        <a href="#" id="scroll_totop"></a>
	</footer>

	</section> <!-- End #content-container -->
</div> <!-- End #wrapper -->

    <script>
        var item_urls = [];
        var item_title = [];
        var item_desc = [];
        var item_vid = [];
        var item_img = [];
        var item_season = [];
//        console.log(item_img);
        var item_season_number = [];
        for(var i = 0; i < item_urls.length; i++){
            jQuery("#comedy_slider ul").append('<li></li>');
            
            var seasons = item_season[i].split(" ");
            var season = parseInt(seasons[1]);
            item_season_number.push(season);
        }
        
        jQuery( "#comedy_slider ul li" ).each(function( index ) {  
            var video = "";
            if(index < item_urls.length){
                jQuery(this).html('<div class="">'+
                                  '<a href="'+item_urls[index]+'" target="_blank">'+
                                  '<div style="width:100%"><img class="comedy_img" src="'+item_img[index]+'?size=300"/><div class="cmd_title" style="background-color:#fff;">'+ 'S0'+item_season_number[index]+': ' + item_title[index]+'</div><div class="cmd_desc" style="background-color:#fff; color:#545353;">'+item_desc[index]+'</div>'+
                                   '</div></a></div>'
                );
            }
            else{ 
                console.log("file unavailble");
            }
        });
        
    </script>

            <script src="//cdn.goroost.com/roostjs/7mf4mc17ymtl9cgeapyoxw3kat6sz6co" async></script>
        <script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><link rel='stylesheet' id='wbq_bootsrap_css-css'  href='/wp-content/plugins/wp-buzz-quizz/modules/inc/assets/css/boot-cont.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='wbqawesome.min.css-css'  href='/wp-content/plugins/wp-buzz-quizz/modules/inc/font-awesome-4.1.0/css/font-awesome.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='wbq_front_css-css'  href='/wp-content/plugins/wp-buzz-quizz/modules/css/front.css?ver=4.7.4' type='text/css' media='all' />
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/vendor.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themeajax = {"url":"https:\/\/www.thebeaverton.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/themes/thevoux-wp_beav/assets/js/app.min.js'></script>
<script type='text/javascript' src='https://www.thebeaverton.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.1.1'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.1.1'></script>
<![endif]-->

 <!--Start: DTM footer to be placed at bottom of the body or footer-->
    <script type="text/javascript">_satellite.pageBottom();</script>
 
    <!--End: DTM footer to be placed at bottom of the body or footer-->

</body>
</html>